Latest RSS feed ignore "Suppress category from latest topics" setting

Go to the settings of some topic and check “Suppress category from latest topics.” then post something to that topic. It is correctly not shown in the Latest tab, but when you open the RSS feed then it contains the post.

Can be seen here:
Projects in Copr - Fedora Discussion
this category has “Suppress category from latest topics.” set to on. There is a lot of new topics.
Fedora Discussion
does not show those topics, however
shows topics from Projects in Copr category.

You are better off muting the category for all users.

How this can be achieved? I did not find any relevant settings.

You can set a list of categories that are muted for all new users on your site by adding the categories to the default categories muted site setting. User’s can override this setting on their categories preferences page.

Muting categories for existing users can be done from the site’s rails console. There are details about how to do that here: How do I set category tracking level defaults historically. To update category tracking levels for sites that are on our hosting, get in touch with our support system and we’ll make the change for you.

1 Like

When trying to add a category to the default categories muted site setting and then saving, it looks like the UI already supports applying the change historically:

If this works as indicated, there should be no need to use the site’s rails console :ok_hand:


Hi @Miroslav_Suchy1,

We made it way easier to set muting historically, just amend the default site setting and a pop up will show up.

Suppress category from latest is about to be removed altogether from the product.

Let us know if you need a hand here.


This topic was automatically closed after 29 hours. New replies are no longer allowed.