Latest update requires cache purge in CloudFlare


(Diego Barreiro) #1

I think if you access to my community is enough to see the problem :confused:

EVEN ON SAFE MODE IS BROKEN


Forum CSS broke completely after upgrade due to Cloudflare
Styling Seems to be Missing because CloudFlare broke our site
V1.9 Not displaying correctly (Missing CSS?)
Design Broken after Upgrade due to Cloudflare
(Joshua Rosenfeld) #2

@barreeeiroo, that’s certainly strange, especially safe-mode not working.

Can you try to SSH into your server and run:

cd /var/discourse
git pull
./launcher rebuild app

(Diego Barreiro) #3

I’ve already done that, except for the git pull
I’ll try now :+1:


(Pad Pors) #4

it didn’t help, ours has the same problem.


(Joshua Rosenfeld) #5

I’m testing this upgrade on my sandbox as I type this, one moment…

Edit: No issues on my sandbox: https://test.jomaxro.win/

Can you both clarify all the non-official plugins you use?


(Diego Barreiro) #6

Even the Sandbox with all plugins disabled and all themes disabled happens
I think it’s not an issue with it :confused:


(Pad Pors) #7

I’ve removed all the plugin after the problem, and rebuild. but it hasn’t been resolved.

anyway here it is:

I think they’re reporting the same issue:

https://meta.discourse.org/t/css-theme-templates-not-loading/73161?source_topic_id=73166

(Joshua Rosenfeld) #8

Yeah, trying to find common links here. @Pad_Pors, @barreeeiroo, are you running tests-passed or stable?


(Brock) #9

We have the same issue with the theme as of beta14. Tested in Chrome and Safari, and in incognito and still same issue.

Here are our plugins. They are up to date on our installation.


(Diego Barreiro) #10

I have in common with you the AdSense plugin
Maybe it could be that, but I don’t think so


(Pad Pors) #11

running on test-passed.


(Joshua Rosenfeld) #12

@Pad_Pors, any chance you’re also running the discourse-adplugin?


(Pad Pors) #13

no, we don’t use it.

I can remove plugins again if it helps. I’e tried this removal 3-4 times in the past 5-6 hours :wink: perhaps hoping for some miracles to happen!


(Diego Barreiro) #14

This is the third rebuild I’ve done, but still not working
Now crashing even after git pull and ./launcher cleanup


(Joshua Rosenfeld) #15

I trust that you’ve tried removing plugins, again just trying to connect the dots here. It doesn’t appear to be a RTL text issue, because the other affected sites are LTR. @Pad_Pors site looks like it’s using Latest as the homepage, @barreeeiroo’s looks like Categories + Latest. I’m honestly not sure what’s going on here…

@barreeeiroo is using CloudFlare, I saw that page during a rebuild. Is everyone else using CloudFlare?


(Pad Pors) #16

Thanks for your effort :heart: I was just trying to help.

yes, we’re using cloudflare as well.


(Joshua Rosenfeld) #17

OK, assuming everyone is using CloudFlare, can everyone confirm that RocketLoader is disabled? Also, in DNS settings is the cloud orange (traffic through CloudFlare) or grey (DNS only).


(Pad Pors) #18

yes, Rocketloader is off. and DNS setting is cloud orange.


(Joshua Rosenfeld) #19

OK, just to check can you try switching to DNS only (grey)? Let that request process and see if that fixes things. You may also want to try purging the CloudFlare cache. (Again, just stabbing in the dark here…)


(Brock) #20

I can confirm we do not have Rocket Loader enabled.
I can also confirm we did not make any changes to Cloudflare within past few days.

Ok, I unchecked the orange cloud to grey. Purged cache. We are also bypassing the cache but still same result. I tried in incognito mode.

Note: it is not an option for us for Cloudflare to be grey due to security. We’ve been using Cloudflare since we launched 1.5 years ago.