Latest update requires cache purge in CloudFlare

I could see our css has come back to normal for some seconds after DNS has changed to grey.

but after a while we get “insecure connection problem”. and I can’t confirm it!

Your connection is not secure

do you know how to remove the insecure connection problem?

@Pad_Pors looks like your Let’s Encrypt SSL cert expired in May. Were you using a CloudFlare certificate, that now isn’t being used as traffic isn’t going through CloudFlare?

1 Like

Going “grey” means you do not use any Cloudflare features. Thus, you were likely using the default SSL setting in Cloudflare or have a SSL page rule set, and when you turn off Cloudflare, then SSL isn’t being applied.

I can confirm that for you

The browser page says that the certificate expired on May 22, 2017 now…


I accessed through IP and it’s perfectly working

Trying to clear all cache…


I’m little bit confused. more than my knowledge! but I guess I should follow this thread:

am I right?

p.s.: thanks @jomaxro for your experimenting spirit! :slight_smile: I was just reading meta to find out some clue before your experiments!


Enabling Development Mode in Cloudflare is a temp fix for this issue

I’m testing other stuff to check if it’s permanent

1 Like

I’m not sure Cloudflare is the issue here. As I’ve mentioned, we hadn’t done any changes to our code or to Cloudflare, and when beta14 hit, then we have the issue.

Probably in that update some CSS stuff changed (I’m not sure) and it’s wrongly cached and/or processed by Cloudflare

1 Like

We use Cloudflare as a reverse proxy because we get DDoS attcked quite often. We cannot live with Cloudflare in dev mode as that exposes our IP address.


you’re right. but now even if there is a bug in the latest update, it can be reproduced. and the bug can be solved.

1 Like

@RyanK is there any way you can help escalating this for us? Lots of Discourse sites can no longer use CloudFlare due to Rocket Loader breaking us.


  1. Login to Cloudflare
  2. Go to Speed Section of your domain
  3. Uncheck CSS
  4. Go to Caching Section
  5. Click the Arrow next to Purge Individual Files and hit Purge Everything, and then Confirm
  6. Wait a few seconds and check if your site loads properly

And it’s fixed :blush:


Thanks for this temp solution

In our testing, you only need to uncheck CSS.

Keep in mind this sets it so your entire domain isn’t auto minimizing CSS. You may want to create a page rule for your Discourse subdomain and add the rule “Disable Performance”. Keep in mind this turns off all auto-minify, Rocket Loader, etc ONLY for your Discourse subdomain.

I strongly recommend you check “Purge Individual Files” and then type in your Discourse domain with trailing “/*” (slash star). This way you are only clearing all cache on your Discourse instance and not your entire origin domain.

I’ve tried also that, but then Cloudflare said: Purging 1 file…, so I prefered to Purge Everything, as maybe it doesn’t support wildcards :sweat_smile:

Absolutely. Let me see if I can get some eyes on this. We are actually having our company retreat this week so I think everyone is in the pacific timezone :slight_smile:


Mmm, is the Flags tab working? On mine not :confused:
But maybe it’s an issue with a plugin, just to discard a general bug

Thanks heaps Ryan, Hope you enjoy your retreat, we do have a workaround so its not mega super extra urgent.

My solution worked for me. For example, “*” will purge our entire Discourse domain but not our origin.

1 Like

It’s not officially starting for a couple days, but most of the global team is either already in SF or en route