Latest update requires cache purge in CloudFlare

I’m not sure Cloudflare is the issue here. As I’ve mentioned, we hadn’t done any changes to our code or to Cloudflare, and when beta14 hit, then we have the issue.

Probably in that update some CSS stuff changed (I’m not sure) and it’s wrongly cached and/or processed by Cloudflare

1 Like

We use Cloudflare as a reverse proxy because we get DDoS attcked quite often. We cannot live with Cloudflare in dev mode as that exposes our IP address.

2 Likes

you’re right. but now even if there is a bug in the latest update, it can be reproduced. and the bug can be solved.

1 Like

@RyanK is there any way you can help escalating this for us? Lots of Discourse sites can no longer use CloudFlare due to Rocket Loader breaking us.

PERMANTENT FIX:

  1. Login to Cloudflare
  2. Go to Speed Section of your domain
  3. Uncheck CSS
  4. Go to Caching Section
  5. Click the Arrow next to Purge Individual Files and hit Purge Everything, and then Confirm
  6. Wait a few seconds and check if your site loads properly

And it’s fixed :blush:

10 Likes

Thanks for this temp solution

In our testing, you only need to uncheck CSS.

Keep in mind this sets it so your entire domain isn’t auto minimizing CSS. You may want to create a page rule for your Discourse subdomain and add the rule “Disable Performance”. Keep in mind this turns off all auto-minify, Rocket Loader, etc ONLY for your Discourse subdomain.

I strongly recommend you check “Purge Individual Files” and then type in your Discourse domain with trailing “/*” (slash star). This way you are only clearing all cache on your Discourse instance and not your entire origin domain.

I’ve tried also that, but then Cloudflare said: Purging 1 file…, so I prefered to Purge Everything, as maybe it doesn’t support wildcards :sweat_smile:

Absolutely. Let me see if I can get some eyes on this. We are actually having our company retreat this week so I think everyone is in the pacific timezone :slight_smile:

3 Likes

Mmm, is the Flags tab working? On mine not :confused:
But maybe it’s an issue with a plugin, just to discard a general bug

Thanks heaps Ryan, Hope you enjoy your retreat, we do have a workaround so its not mega super extra urgent.

My solution worked for me. For example, “https://discussions.ftw.in/*” will purge our entire Discourse domain but not our origin.

1 Like

It’s not officially starting for a couple days, but most of the global team is either already in SF or en route

I’m going to grab one of the lead engineers when he steps out of his next meeting. He’ll want some example URLs.

Does anyone have any URLs that show the issue still happening? We aren’t seeing it on our instance as far as I can tell.

I believe @jomaxro can provide you with more detail than you would ever possibly want, and then some :wink:

just kidding I :heart: you Josh

2 Likes

@jomaxro if you want to PM me as much detail as you have I can get that ticket filed ASAP

I had the same issue.

Unchecking Js, CSS and HTMl will apply to all pages of your websites.

Instead, I think it is best to add the page rule “Disable performance” ( for your forum only ).
And then clear your cache.

It worked for me.

I already tried that but didn’t worked

This is strange, it worked for me.

Have you clear you browser cache too ?

Pretty sure you guys are just seeing bad assets get cached for whatever reason. The cloudflare problem @jomaxro worked on is related to /admin routes only.

2 Likes