Latest update requires cache purge in CloudFlare

I’m going to grab one of the lead engineers when he steps out of his next meeting. He’ll want some example URLs.

Does anyone have any URLs that show the issue still happening? We aren’t seeing it on our instance as far as I can tell.

I believe @jomaxro can provide you with more detail than you would ever possibly want, and then some :wink:

just kidding I :heart: you Josh


@jomaxro if you want to PM me as much detail as you have I can get that ticket filed ASAP

I had the same issue.

Unchecking Js, CSS and HTMl will apply to all pages of your websites.

Instead, I think it is best to add the page rule “Disable performance” ( for your forum only ).
And then clear your cache.

It worked for me.

I already tried that but didn’t worked

This is strange, it worked for me.

Have you clear you browser cache too ?

Pretty sure you guys are just seeing bad assets get cached for whatever reason. The cloudflare problem @jomaxro worked on is related to /admin routes only.


Yes :confused:
I’ve tried any option releated with Cache, but only mine worked :sweat_smile:

Maybe if this helps :confused:

Yeah, I’m testing the Discourse Classic Theme :sweat_smile:

Well, the most important is that it works for you now :+1:

1 Like

I’ve noticed another bug with cloudflare. It seems that their firewall blocks the update process.

So I have to deactivate their WAF rules before upgrading. Not big deal, but thought you should now.

I’m running in and out of meetings and having trouble following. Also, I’m woefully un-technical. Do any of the above responses contain example info the engineers can use to troubleshoot?

Nope you need to wait for @jomaxro to contact you directly. Everything here in this topic can be 100% ignored.

1 Like

Thanks. Is the issue that @carlo is reporting system wide? I can file that as well.

Unlikely. I would 110% wait for @jomaxro. Basically the people in this topic are saying “purge your cache” which is not :rocket: science.

@codinghorror Purge Cache only doesn’t work
I had to disable CSS Minimize too and then Purge Everything

1 Like

Ok so you saw issues with the CSS minimize feature then? Can you repro that @jomaxro?

If I enable it, I get the wrong design again

Maybe CSS stuff cloudflare is doing is breaking due to CSS vars I added for onebox fix.

Yes, I was able to reproduce the minification issue, I shared the details with Ryan via PM.