./launcher bootstrap app fails with "Could not find rake"


(Bob Liu) #1

I install discourse with this doc https://github.com/discourse/discourse/blob/master/docs/INSTALL-digital-ocean.md

but when I ./launcher bootstrap app I get the error log

I run as root, and my linux is gentoo on linode

2015-02-09 04:03:11 UTC LOG:  received fast shutdown request
2015-02-09 04:03:11 UTC LOG:  aborting any active transactions
2015-02-09 04:03:11 UTC LOG:  autovacuum launcher shutting down
2015-02-09 04:03:11 UTC LOG:  shutting down
I, [2015-02-09T04:03:11.763538 #44]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 184
[184 | signal handler] (1423454591) Received SIGTERM scheduling shutdown...
2015-02-09 04:03:11 UTC LOG:  database system is shut down
[184] 09 Feb 04:03:11.808 # User requested shutdown...
[184] 09 Feb 04:03:11.808 * Saving the final RDB snapshot before exiting.
[184] 09 Feb 04:03:11.810 * DB saved on disk
[184] 09 Feb 04:03:11.810 # Redis is now ready to exit, bye bye...


FAILED
--------------------
RuntimeError: cd /var/www/discourse && su discourse -c 'bundle install --deployment --verbose --without test --without development' failed with return #<Process::Status: pid 280 exit 7>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
94c259a7b53a91fc308a490909484354ab8ef0c9c03a08503c583edd8408fa6f
FAILED TO BOOTSTRAP

(Sam Saffron) #2

need a few more lined of the logs, guess is that rubygems is playing up.


(Sam Saffron) #4
HTTP 200 OK
Fetching source index from https://rubygems.org/
Could not find rake-10.4.2 in any of the sources

looks like its meant to be there rake | RubyGems.org | your community gem host so intermittent rubygems issue, try again in an hour or so.


(Bob Liu) #5

Yes, you are right. After trying again, it works now.


(Jeff Atwood) #6