./launcher rebuild app for old 1.6 discourse not working

final piece of the puzzle here for me

I have my old forums that i have just moved to a new location but i still need access - i edited the app.yml to change the domain name and then ran ./launcher/ rebuild app --skip-prereqs to have it update but it fails

Ensuring launcher is up to date
Fetching origin
Launcher is up-to-date
Stopping old container
+ /usr/bin/docker stop -t 60 app
2.0.20230116-0051: Pulling from discourse/base
e01f084ee363: Already exists 
db2fb8a75c87: Already exists 
6e789f3cf3a6: Already exists 
afa15f3b4f49: Already exists 
bd9a8f354aab: Already exists 
7492e41ba139: Already exists 
17620c643046: Already exists 
24a2215b994e: Already exists 
3119b33deb35: Already exists 
32a8b7f7c0e8: Already exists 
2dbcf46b2450: Already exists 
bdc228d4887d: Already exists 
914f28af582f: Already exists 
4a67c541b202: Already exists 
d3fc17f1b671: Already exists 
77b3d250e54b: Already exists 
9329aa462aa8: Already exists 
daeee236a97d: Already exists 
b7746b7c02a0: Already exists 
5c28ac2537d4: Already exists 
56d3ef9b7e39: Already exists 
3bb00ba1ec5a: Already exists 
1f758f6d6132: Already exists 
374c5f9048f9: Already exists 
0259a5d2f899: Already exists 
3ad74725ef87: Already exists 
f61c04c40065: Already exists 
1917d29aeb87: Already exists 
6bf5a4e9b5be: Already exists 
0f99e9c433c1: Already exists 
5c757ebc11e3: Already exists 
eb1d61649fc0: Already exists 
b3fce4a2403d: Already exists 
2252a5634a08: Already exists 
3b67775f0e8d: Already exists 
fb7e87c0cabf: Already exists 
f0ba17f026a5: Already exists 
aa579fdb2c50: Already exists 
9b282f6a881a: Already exists 
e60b39d46409: Already exists 
4e9e640a98df: Already exists 
0d2ba21fdd7e: Already exists 
5871f9f51cef: Already exists 
2a25ca72ae61: Already exists 
a6b1f035e2fa: Already exists 
4f13760fda63: Already exists 
856119d0afd5: Already exists 
0d289e5416ba: Already exists 
7ee9fa0f4507: Already exists 
aa6751fe4791: Already exists 
a586d833efb5: Already exists 
769ebf485619: Already exists 
701cfc339927: Already exists 
Digest: sha256:xxx
Status: Image is up to date for discourse/base:2.0.20230116-0051
/usr/local/bin/pups --stdin
flag provided but not defined: --shm-size
See '/usr/bin/docker run --help'.
cat: cids/app_bootstrap.cid: No such file or directory
bootstrap failed with exit code 2
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
Container name cannot be empty

DISCOURSE DOCTOR Tue Jan 24 13:46:45 GMT 2023
OS: Linux xxxx01 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:28:38 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Found containers/app.yml

==================== YML SETTINGS ====================
SMTP_ADDRESS=smtp.xxxxx.com # (mandatory)
SMTP_PASSWORD=xxxxx # (optional)
SMTP_PORT=25 # (optional)
SMTP_USER_NAME=xxxxx # (optional)

==================== DOCKER INFO ====================
DOCKER VERSION: Docker version 1.7.0, build 0baf609

DOCKER PROCESSES (docker ps -a)

CONTAINER ID        IMAGE                 COMMAND             CREATED             STATUS                      PORTS               NAMES
456040e68bec        local_discourse/app   "/sbin/boot"        6 years ago         Exited (5) 52 minutes ago                       app                 
91834fc0d913        hello-world           "/hello"            7 years ago         Exited (0) 7 years ago                          ecstatic_poitras    

==================== SERIOUS PROBLEM!!!! ====================
app not running!
Attempting to rebuild
==================== REBUILD LOG ====================
ERROR: Docker version 1.7.0 not supported, please upgrade to at least 17.03.1, or recommended 17.06.2
==================== END REBUILD LOG ====================
Failed to rebuild app.

Checking your domain name . . .

Connection to xxxx.xxxxxx.com succeeded.
You should probably remove any non-standard plugins and rebuild.
Attempting to restart existing container. . . 
ERROR: Docker version 1.7.0 not supported, please upgrade to at least 17.03.1, or recommended 17.06.2
Failed to restart the container.

==================== PLUGINS ====================
          - git clone https://github.com/discourse/docker_manager.git
          - git clone https://github.com/discourse/discourse-solved.git

No non-official plugins detected.

See https://github.com/discourse/discourse/blob/main/lib/plugin/metadata.rb for the official list.

Discourse version at xxxx.xxxx.com: NOT FOUND
Discourse version at localhost: NOT FOUND

==================== MEMORY INFORMATION ====================
RAM (MB): 4048

             total       used       free     shared    buffers     cached
Mem:          3953       2058       1894          0         13       1811
-/+ buffers/cache:        233       3719
Swap:         2047        134       1913

==================== DISK SPACE CHECK ====================
---------- OS Disk Space ----------
Filesystem      Size  Used Avail Use% Mounted on
/dev/vda1        79G   66G  9.5G  88% /

==================== DISK INFORMATION ====================

WARNING: GPT (GUID Partition Table) detected on '/dev/vda'! The util fdisk doesn't support GPT. Use GNU Parted.

Disk /dev/vda: 85.9 GB, 85899345920 bytes
255 heads, 63 sectors/track, 10443 cylinders, total 167772160 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

   Device Boot      Start         End      Blocks   Id  System
/dev/vda1               1   167772159    83886079+  ee  GPT

==================== END DISK INFORMATION ====================

==================== MAIL TEST ====================
For a robust test, get an address from http://www.mail-tester.com/
Or just send a test message to yourself.
Email address for mail test? ('n' to skip) [xxxxxx]: n
Mail test skipped.
Replacing: Sending mail to

==================== DONE! ====================

If you moved the entire install across did you try to just start the container before attempting an upgrade?

If you have a backup why not restore it to a fresh installation?

You’re attempting to rebuild from 1.6, which should work, but is far more headache.

Why skip prereqs? As you’re rebuilding that doesn’t skip the update, only the checks which save you from harder to troubleshoot error messages.

Can you update docker while you’re at it?

1 Like

i already performed the upgrade to 3.1, its now running fine.
I’m trying to bring the old forums - which were untouched - back online for development

skipping prereqs because i can’t use the launcher rebuild command without it - docker running v1.7 and v1.8 required - but perhaps this is the issue so i’ll try updating that now.
Just a bit confused because i haven’t updated these forums so i don’t understand why the rebuild isn’t working as i haven’t changed any dependencies etc.

only thing i’ve changed is the app.yml to update the hostname and tried running rebuild, which wont work without skipping prereq

The latest launcher and Docker image isn’t compatible with Discourse 1.6. You’ll need to checkout an older version of discourse_docker. Something like git checkout 2ec550f could work…

1 Like

It’s a good bet that your OS is also beyond end of life, but in any case, I would recommend that you make a backup, create a new installation on a new vm and restore the backup to the new one. This will also save you some steps required to Change the domain name or rename your Discourse.

i can no longer do that as i can’t restart the app anymore

If you have a backup of the old folder you can always bring that back across and try to start it.

The issue is that you upgraded the base Discourse image.

Then I’d rsync over the /var/discourse/shared directory to the new server.

will that work if i use a newer discourse build on the new server?

1 Like

Why not tell us the outcome you’re looking for here.

Your old instance is currently 1.6 - but your title suggests you want to run a rebuild, which will also upgrade it - is that correct? If so then yes, restoring to a fresh new install will be less painful.

If you’re just looking to start the 1.6 instance instead of upgrade then the advice will be different. Without the hostname change thrown in you would usually just copy the contents of /var/discourse between servers. As long as the destination machine has docker installed it can just be fired up using ./launcher start

1 Like

i just want access to the old forums as there were some posts that were not carried across to the new installation (slightly out of date backup)

i wanted to notify those users, but i cannot get the 1.6 version back up and running - i didn’t want to update it but it doesn’t matter if it is updated, i just need access is all

what do i do if there is a hostname change though?

Yes. It should work.

1 Like