LDAP plugin always auth_overrides_username

We habe a serious issue after updating to the latest 2.8.0.Beta10: disabling the setting

auth_overrides_username

seems to have no effect. The box is unchecked, but after every Logout/Login process, the user-selected username is overwritten with the LDAP name. Can someone confirm this?

At the moment the LDAP plugin specifically enables the overrides_username setting. Maybe it should simply rely on core’s auth_overrides_username setting, or introduce a new site setting.

The LDAP plugin is not an official plugin, and I don’t think the author is active here on Meta, so you might need to open an issue on the repository.

1 Like

Thanks for the quick response. Is this already solved by this PR?

1 Like

That won’t fix it. Although now that you mention it, that PR probably introduced this behaviour change.

Some context: we removed an old ‘omit username’ flag from core, which the LDAP plugin was using. It was extremely similar to the overrides_username setting, which is why I simply substituted them in the LDAP plugin. However, as you’ve noticed, omit_username only applied during initial signup, while overrides_username applies on every login.

Here’s a PR to reverse that behaviour change. We’ll need @jonmbake to merge

1 Like

@Ralf_Stockmann that PR is now merged, so the old behaviour should be restored once you update the plugin

1 Like

This topic was automatically closed after 15 hours. New replies are no longer allowed.