Links broken after move

Many of our intra-forum links are broken after moving to a new server. I had created the new server at a temporary url to help with the transition, but now that the transition is complete, many links at still point to (which no longer exists).

I have verified the app.yml and rebuilt:

containers/app.yml: DISCOURSE_HOSTNAME:

I have searched admin > settings for any vestiges of “staging”.

DNS has long since propagated.

I see this old reference, not sure if that’s related.

If no fix is possible except manual editing, any hints how to find all occurrences? The search button doesn’t work well for this.


I did that. All worked great except now I have broken links.

So you’re saying the remap and/or rebake failed?


Sorry, I did not do a remap. I’ll try that tonight.


Yes, now I can say the remap failed.

> /var/www/discourse# discourse remap
> Rewriting all occurences of to
> Error: ERROR:  duplicate key value violates unique constraint "unique_post_links"
> DETAIL:  Key (topic_id, post_id, url)=(8718, 57455, already exists.
> The remap has only been partially applied due to the error above. Please re-run the script again.

I re-ran it as instructed and got the same error, on the same (topic_id, post_id, url) key.

I can get to the rails console and run some SQL/ActiveRecord if you can tell me what to run. Or Data Explorer.

Someone else will have to help you with this because I’m not sure why you would have duplicate key value.

Ironically, the offending topic 8718 and post 57455 is in a PM between two users lamenting that the links are broken!

But using data explorer, I see only one post with id 57455. I don’t know why remap is complaining.

1 Like

The post probably contains both the old and new URL already. Just edit it and remove them.


I cleaned up a few posts and was able to complete the remap. However the rebake ran to 30% then encountered errors and hung the system and I had to reboot. System has adequate memory and disk space.

Question: After reboot, in ‘top’, there is a ruby process using 60% CPU. Is that the rake job? Would it resume after reboot?

It’s probably Sidekiq busy on rebakes. Go to /sidekiq on your forum to check.

1 Like