Links in emails are using http instead of https

I have successfully completed all the steps to setup a discussion forum for my company.
I have TLS enabled and force_https is checked in settings.
The activation emails to new users are sent with http instead of https. e.g
Welcome to Folio3 NS Community!

Click the following link to confirm and activate your new account:
I check the email tempate in settings from UI , and there is a variable base_url which is containing http and my domain name.
Any ideas on how to update the base_url, so that it contains http instead of https.
(My site is accessible by https not http)
M. Saqib

If i go to your site I do not get the https version of it

This will mean, that emails that are sent with give the http:// version as it also dont get the https:// version

the email is setup like this:

Welcome to %{site_name}!

Click the following link to confirm and activate your new account:

If the above link is not clickable, try copying and pasting it into the address bar of your web browser.

I would suggest you look at your https:// setup. Once you fix that, your email links will be fixed.

My site is hosted at

and not

Another application(gitlab) is hosted at port 80 i.e http.
Do you mean, I have to add a rediection to https on my port 80 , to make the base_url string get the correct https in the beginning?

Sounds like you need to go through this guide:


It was my bad. I somehow missed the settings “force_https” and it was showing checked to me. (may be browser caching)
Another developer from my team checked that option and the emails are now received having links correctly as https.

Thank you all for your valuable comments!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.