Living with corrupted SVGs for almost a year. Need Help!

Hey everyone,

We need your help identifying where to dig on our side. The errors code shows is not enough for us to understand what we might fix. In the same time, we got no specific feedback on these reports in corresponding Discourse GIFs topic here:

The specific log entry in the Discourse says:

discourse-gifs theme contains a corrupt svg upload : Errno::ENOENT : No such file or directory @ rb_sysopen - /var/www/discourse/public/uploads/default/original/1X/f12ce05b66e5cb7eba2bb0dbf1aa2712ef20

While we do not have /var/www/* at all.
I tried deleting/installing theme component. I tried deleting it and uploading it as s local .zip file from github repo. I tried flushing redis cache within discourse app console. Nothing helped.

What should we look into if this is not a code problem? Current version is: 3.1.0.beta2 6fc2cded55


I must add that Discourse TOC produces the same error of:

Error with icons-sprite: #<TypeError: no implicit conversion of nil into String>


No ideas? :frowning: I don’t know where to find any clues…

1 Like