Locations Plugin


(Angus McLeod) #305

@Richie Thanks for your patience. Between you and me, you’re my favourite bug reporter :wink:

Should be fixed now:

Likewise:


(Rich) #306

Hi @angus

Update installed this morning - confirmed both issues resolved :man_dancing:

Thanks once again for your dedication to this pluging my good man :slight_smile:


(Keven Naphtali) #307

Latest update to discourse makes map icons go bye bye. :frowning:


(Rich) #308

Just updated to v2.2.0.beta5 +61 and our are still present:

Are these the map icons you meant @keven mate?


(Angus McLeod) #309

@keven Indeed, a few icons were affected. Now fixed.

add map-o svg registration · angusmcleod/discourse-locations@009300f · GitHub

add info svg and tweak map icon styles · angusmcleod/discourse-locations@44a15b0 · GitHub

cc @Richie


(Rich) #310

Update installed, although strangely I wasn’t seeing this issue. Cached perhaps? :thinking:

Thanks for the continued updates and support @angus :+1:


(Rich) #311

Uh-oh…

Installed the latest v2.2.0.beta5 +126 this morning and our entire user map has broken @angus :cry:

Any ideas mate? :thinking:


(Keven Naphtali) #312

Good to know. Also, I see your map expand icon is missing too as is mine in v2.2.0.beta5 +95.


(Angus McLeod) #313

@Richie See if this fixes it

@keven I’ve also registered the expand icon


(Rich) #314

Hi @angus sadly not…

The map Expand Icon is fixed, but we still have no user pins on the map:

Now running:

v2.2.0.beta5 +136


(Angus McLeod) #315

@Richie I’m pretty sure this issue is specific to your site. I’ll pm you about it.


(David Kingham) #316

Mine is broken as well, just updated everything. No pins show up on the users map.


(Angus McLeod) #317

@Richie @davidkingham This should fix it guys (it fixed it on my sandbox).


(Rich) #318

Update installed this morning @angus - confirmed working :clap:t2:

Thanks as always for your continued support on this great plugin :bowing_man:


(Thomas K. Running) #319

Thanks @angus for yet another amazing plugin!

I was wondering if any of these features are on your roadmap?

  • Automatically updating a user’s location on the map based on their last known IP address (obviously opt-in, and ideally only at a city level)
  • Which leads me to: an option to only show user’s location on a city level (could use this API for that: Teleport public APIs - Teleport Developer Program)
  • An option to only show the user map to logged in users. I think many of my users are unlikely to share their location completely publicly.

In my case (a community for nomads, frequent travelers, and remote workers), users’ locations are likely to change very often, and it’s unlikely that many will manually update their location every time they step on a plane, so some sort of automatically updating location would be very useful.

While I worked at Teleport we launched a product called Sundial which primarily is a way for remote teams to show their members on an interactive map (e.g. see GitLab’s team page).

That’s basically what I would love to provide to my community, to make it easier for people to meet up in real life when they happen to cross paths.

While my Ruby skills are quite limited (the most I ever did was this fork of the affiliate plugin), do let me know if there’s any way I can help or contribute to make any of these features easier to implement :slight_smile:


(Rich) #320

Hi @tkrunning :wave:t2:

We manage this through the use of a Discourse setting:

Not sure if that’s an ideal setting for you to use, but it will solve the concerns your users may have :+1:t2:


(Jeff Vienneau) #321

@angus, I upgraded my discourse to 2.1.5 from 2.1.4 today and had issues that were resolved by removing my locations plugin.

This seems to be where the things went off the rails in the log:

Successfully installed geocoder-1.4.4
1 gem installed

I, [2018-12-17T19:25:21.677523 #13]  INFO -- : Terminating async processes
I, [2018-12-17T19:25:21.677661 #13]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/10/bin/postmaster -D /etc/postgresql/10/main pid: 69
2018-12-17 19:25:21.678 UTC [69] LOG:  received fast shutdown request
I, [2018-12-17T19:25:21.678000 #13]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 185
185:signal-handler (1545074721) Received SIGTERM scheduling shutdown...
2018-12-17 19:25:21.682 UTC [69] LOG:  aborting any active transactions
2018-12-17 19:25:21.685 UTC [69] LOG:  worker process: logical replication launcher (PID 78) exited with exit code 1
2018-12-17 19:25:21.688 UTC [73] LOG:  shutting down
185:M 17 Dec 19:25:21.689 # User requested shutdown...
185:M 17 Dec 19:25:21.689 * Saving the final RDB snapshot before exiting.
2018-12-17 19:25:21.712 UTC [69] LOG:  database system is shut down
185:M 17 Dec 19:25:21.893 * DB saved on disk
185:M 17 Dec 19:25:21.893 # Redis is now ready to exit, bye bye...


FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 13046 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development --retry 3 --jobs 4'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}
8c993c0a013594b3d83f06507058a0484ab5e0f723de301521f91d616f8b7fe8
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one

Any thoughts?


(Angus McLeod) #322

@Jeff_Vienneau hm, I’m not seeing a similar issue on my sandbox (I just tried rebuilding and it worked).

Can you:

  • Post a longer version of the log (hide it with the “details” functionality)
  • Confirm that you only removed the locations plugin to rectify the issue (i.e. did you do anything else? remove another plugin for instance?)

(Jeff Vienneau) #323

I removed each plugin one by one until it was just the locations plugin and then tried with and without it.


(Jeff Vienneau) #324

Not sure how to do this^^^

Edit: nevermind… You mean discourse details annotation.