Login Modal UI black fades out

Just updated discourse of our client’s website, it seem to be a bug, the Sign up Modal fades out full black with nothing to click.


We have checked with the safe mode, disabled unofficial plugins and all plugin, tried troubleshooting, but nothing seem to be working.

Also, tried enable local logins, but still nothing changed!

1 Like

Unless you can repro here, it is something specific to that site. So either HTML/CSS customization, or third party plugins.


We are suffering from this also. We had Settings/Login/“enable local logins” disabled in our configuration. I tried enabling it (the default?) and the login modal then appeared properly. We do have other providers enabled and this was working until the update.

Also, and possibly related, if I disable local logins again and then click the “Log in” button (instead of “Sign up”), it shows our various auth providers as expected (Facebook, Google, Twitter, Github) and also a “with email” button below them. If I click that “with email” button I get “Please enter your email or username.” shown at the top of the modal, but there is nowhere to enter an email address.

EDIT: I think I have now realised that having “local logins” disabled but “local logins via email” enabled is not supported. I’ve no idea if that has changed but in any case, I’ve now disabled both those settings. This means that “with email” button has now gone from the “Log in” modal, which is fine. And we are back concentrating on the original problem, the “Sign up” modal does not show, it’s just a black overlay as per the OP’s screenshot.