Login Required activated - after successfull login it transfers you to nonexisting page


(Arnel ) #1

Hello to everyone,

I just want to ask if anyone can reproduce it or is it happening just to my discourse forum… When I activate the option in admin section Login Requiered, and when an User logs in, after sucessfull login the discourse forwards him to the page: example.org/menu_links . This menu_links page does not exist. Shouldn’t discourse go to the main domain (example.org/) strait away? How come this /menu_links apears?

Thanks


(Jeff Atwood) #3

No idea, but likely a rogue third party plugin. Try disabling all third party plugins and rebuilding.


(Arnel ) #4

Thank you Jeff.

I’ve done what you suggested. I deactivated plugins one by one and found out that discourse-navigation plugin was faulty when Login Required option in admin section is activated. It is also reported to developer on his github repo…

I hope that it would be fixed soon… because I find it esential to have…


(Jeff Atwood) #5

Ah yes that @vinothkannans he is a bit of a wild card :wink:


(Vinoth Kannan) #6

Hi @arnie, “discourse-navigation” plugin is currently not in active development. Like in your screencast if you want to add icon links in header then use Iconified Header Links theme component.


(Arnel ) #7

Thank you @vinothkannans for pointing on that alternative, but specifically I used your plugin for creating a couple of footer links in hamburger drop-down-menu, and I think this addon theme does not support that functionality. Okay for now I’ll search for alternative way. Thanks


(Tobias) #8

Let me know what you find, cause i need this specific option, too. I don’t like to put that much in the header :slight_smile:

And, it’s sad to hear that the development is not active anymore.


(Arnel ) #9

I found a alternative solution here:

Chears :slight_smile:


(Tobias) #10

Hi,

Thanks for the reply. I added the same on the issue, the same day :slight_smile:


(Arnel ) #11

New solution using theme component: