Login with Google account, breaks using gmail email to create account


We’ve recently setup google login for discourse, since then we’re unable for users to create accounts using gmail email addresses instead of the google login feature. When a user signs up using a gmail email address, no emails are sent.

The guide was followed here: Configure Google login for Discourse

The login with google flow works fine and the server can send emails to gmail accounts no issue. Do we need to enforce users to only use the login with google flow (if so, how?) or should both work in parallel.

1 Like

Also, users logged in via an SSO (Google) still have access to the 2FA features within the My account > Security tab. It prompts them to enter a password, yet they don’t have a local account due to using google.

Should this be hidden automatically or how is it best managed?

1 Like

Seems to be unrelated and coincidental. Mailjet have an on-going issue sending to gmail email addresses.

Is there anyway to disable 2FA options for SSO logins?