Logo stopped updating if dark mode is enabled


As we all know, discourse allows using different versions of logo for light/dark modes, a feature that I’ve been using for quite a while and it was working perfectly until I’ve updated Discourse to 2.9.0 beta 5, in which the logo is no longer updated once the dark mode is enabled and I see the “light” theme logo.

There were no other changes to the website, I’ve tried disabling custom plugins and clearing cache/incognito – the issue persists.

Could it be that it was somehow broken in new beta? Or how should I troubleshoot?

We had a dark mode bug shipped a few days ago that was corrected in the same day. Since the dark logo is working here on Meta at the moment can you try updating?

1 Like

i’ve pulled all updates to discourse, but it’s still not working.

Moreover, I’d disagree with


And I actually can reproduce the same behavior as on my own instance. If I go to preferences/interface, and manually change dark to dark, I see the proper logo, but it vanishes the moment I reload the page.

What is the theme / pallete for that?

It’s shown on my second screenshot, isn’t it? It’s the default Meta theme

I mean when it’s showing the wrong logo, in the second screenshot it’s showing the correct logo.

Ohh I see now, the combo is Dark - Light / Dark in settings.

Actually, I have to update my statement:

If I save changes, things start working. So I believe I’ve accidentally duplicated

1 Like