Manual upgrade fails

Hi

– trying to manually update old Discourse by these instructions

Keep getting this error:

Pups::ExecError: apt-get update && apt-get install -y postgresql-9.3 postgresql-client-9.3 postgresql-contrib-9.3 failed with return #<Process::Status: pid 18 exit 100>

Location of failure: /pups/lib/pups/exec_command.rb:112:in `spawn’

exec failed with the params “apt-get update && apt-get install -y postgresql-9.3 postgresql-client-9.3 postgresql-contrib-9.3”

a2bd7274278e546582a98ef46371b18564f416c2cadaa46a6ec6c58a5a3f162f

** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.

./discourse-doctor may help diagnose the problem.

I upgraded to Ubuntu 18.04.3 LTS and added disk size well above double the db size.

Any ideas?

1 Like

:scream: :scream: How old is your Discourse install? On what version are you?

3 Likes

seems to be [v1.9.0.beta17 +38]

1 Like

Time for an upgrade. Discourse is up to v2.4.0.beta10.
There have been a lot of changes, updates, improvements, etc. :wink:

Have you got it working?

I have no expertise in this area but it looks like it is failing when trying to get Postgres 9.3.

But that was upgraded to 9.5 back in 2016 and you are using Discourse version 1.9 which is from 2018?

Maybe it is related to this issue:

Right now I don’t have time to read these topics. I just noticed no help for 2 days.

1 Like

Time for an upgrade. Discourse is up to v2.4.0.beta10.
There have been a lot of changes, updates, improvements, etc. :wink:

Yes. I’m trying to upgrade. The problem is that the upgrade fails.

In just want an up-to-date Discourse, with the old stuff preserved.

How to do that?

1 Like

I don’t understand why you are using an older version of PostgreSQL than would have been installed or upgraded for [v1.9.0.beta17 +38]

Did you install by some method other than the official Discourse install method? See the official install method at discourse/INSTALL.md at master · discourse/discourse · GitHub

Whatever you do make sure that you have a backup.

Check that you have enough disk space for the PostgreSQL upgrade. They say you need free space twice the size of the database:

The other two topics I posted previously may also help but I’m not sure of the source of your problem.

1 Like

"I don’t understand why you are using an older version of PostgreSQL than would have been installed or upgraded for [v1.9.0.beta17 +38]

Did you install by some method other than the official Discourse install method? See the official install method at discourse/INSTALL.md at master · discourse/discourse · GitHub"

Me neither. :slight_smile:

I have upgraded via the /admin section at the webservice.

Now the webservice says I have to update manually.

Manual upgrade fails.

That is the situation.

I wonder of there is a way to manually upgrade PostgreSQL first, then try to upgarde Disocurse. Would that work?

1 Like

That PG 9.3 is really old, and it doesn’t sound right for a v1.9 Discourse install.

If I were you I would make a backup, create a new host with an up to date Discourse, restore the backup and move the hostname to the new server.

6 Likes

Do you have a separate data container or are you using an external database?

In any case, I would first try the route that Richard just suggested.

5 Likes

Do you have a separate data container or are you using an external database?

How can I tell? I mean, how do I know/find out?

1 Like

If I were you I would make a backup, create a new host with an up to date Discourse, restore the backup and move the hostname to the new server.

Ok, I think I’ll try this.

4 Likes