Master branch giving blank page for dev


#1

Have been using developer vagrant installation of Discourse (as detailed in Discourse as Your First Rails App), but recently I have been getting a completely blank page on browsing to localhost:4000 for the master branch of discourse. The F12 errors, Chrome is throwing out, are the following:

Uncaught Error: Could not find module discourse/lib/raw-handlebars
Uncaught Error: Could not find module `discourse/widgets/post-cooked` imported from `discourse/lib/plugin-api`
Uncaught TypeError: Cannot read property 'startRouting' of undefined (ember:3477 )

The relevant actions that I performed on my system since the last time the dev installation was working correctly were:

  • Using an updated version of rubygems v2.2.5
  • At some point I noticed getting the “Migrations are pending bin/rake db:migrate RAILS_ENV=development” error on localhost:4000. Tried the solution mentioned here, after which I started getting the blank page.
  • Installed (and later uninstalled) PostgreSQL-9.6.0 on Windows.

The previous branches (like stable (23rd September)) works fine. What could be the issue here?


(Sam Saffron) #2

are you running Ruby 2.3 ?


#3

The ruby-v command in vagrant ssh is showing: ruby 2.3.1p112 (2016-04-26 revision 54768) [x86_64-linux].
Although, outside of vagrant I have Ruby v2.1, but I suppose this should be irrelevant?


Forum showing blank page on Desktop due to Cloudflare "optimizations"
(Alan Tan) #4

In your Discourse directory, try removing the tmp directory.


#5

Yes, that solved the issue. Thanks for that, much appreciated.
The handlebars, ember errors in Chrome confused me. If it isn’t too much trouble, any explanation to how tmp files could be throwing out ember errors?