“Math Processing Error”

Hi !

First of all, thank you for that great plugin :slight_smile:

I encounter an issue which happens from time to time:

The error message is “Math Processing Error”.

If I reload the page, the error message disappear and the formula appears.

Any idea how I can avoid this ?

1 Like

Do you notice a pattern for what is causing the error? For example, does it only occur in posts that have a lot of formulas in them?

When the error happens again, if you are able to open your browser’s web inspector to its console tab, it is possible there will be some relevant errors. If you could share those with is it might help to debug the issue.

1 Like

Hi Simon,

So I dug into the problem and here are my observations:

  • It is not related with the number of formulas
  • Web inspector doesn’t show any problem
  • It happens on formulas which contain an array (such as matrix) - \begin\array

The problem does not appear randomly, there is a precise way to reproduce it:

  1. I have to go on my Discourse forum homepage, using anonymous mode in browser
  2. I have to open any topic which does not contain an array
  3. Then come back to homepage
  4. Then go in a topic which contain an array : the problem occurs
  5. If I reload, the problem disappears (or if I go to any other topic with array inside, no problem)

If I open directly a topic with an array (direct link), the problem doesn’t occur.

I did several searches on the Internet with the keywords “Math Processing Error”, “Math Processing Error latex”, “Math Processing Error mathjax”, “Math Processing Error array”. No result found, so I am wondering if this problem doesn’t happen only to me.

Anyway I switched to KateX, and there is no more problem.

Moreover KateX solved another issue: formulas too long which don’t fit mobile screen.

I had another issue when I use “!” (factorielle) in a formula, which triggered another error message “Undefined control sequence \mathchoice”, randomly without a pattern to reproduce it. I don’t know if this problem is related with the first one, but it was also solved by using KateX.

So my final thought is that I’m gonna use KateX instead of Mathjax.