Message threading in Mail.app


(Allen - Watchman Monitoring) #1

Continuing the discussion from Emails are not threaded in Outlook 2013:

I’m seeing the my iPhone will thread emails I get from Meta, however my Mac OS Laptops won’t. The Mail.app in 10.8 and 10.9 fail to pick up on the relation.

In looking at the headers of messages, I see

In-Reply-To: <topic/27505@meta.discourse.org>
References: <topic/27505@meta.discourse.org>

and I wonder… could the / be throwing off the threading? How could I test it with headers showing:

In-Reply-To: <topic27505@meta.discourse.org>
References: <topic27505@meta.discourse.org>

Has that been tried already?

One way to solve this is to put a Re: at the start of every email, but it’s a bit awkward when the first post is “re” I don’t know if a conditional "Re: " could be added…


#2

Does github emails thread on this client? They use the same concept of IDs.

from Discourse Meta

%{optional_re}[%{site_name}] %{optional_pm}%{optional_cat}%{topic_title}

(Allen - Watchman Monitoring) #3

Github uses / too

Example:

References: discourse/discourse/issues/806@github.com

Thanks for pointing out the how-to topic, I’ve implemented %{optional_re} Nice!


(Kane York) #4

It’s there by default… which means you removed it at some point.


(Allen - Watchman Monitoring) #5

I doubt I removed it… I’ve been using Discourse for a long time and love it :heartpulse: (Despite all my posting about desired changes.) I suspect I started the discourse forums I run before the optional re was a default, but it’s hardly worth digging up.


(Jeff Atwood) #6

I believe you can ask @peternlewis who has extensive experience with this.

Consensus was this is a bug in mail.app with no known workaround other than the re: thing.


(Peter N Lewis) #7

Yes, I believe @watchmanmonitor found the relevant topic and adjusted the subject line config to always start with Re: which makes Mail happy, so its all good.


(Robert) #8

The %{optional_re} is not part of the default anymore. I have the last beta. @riking

I would have expeced that a click on reset would resolve my issue of non-threaded mails. Hower, I was already on the default. I’m using KMail from KDE and the Re is required.