Missing setting: default locale


(Markus) #1

Since the latest updates, we’ve noticed that our default site language has changed from German to English. The global site setting “default locale” isn’t available any more.

How can change the site language again?

Thanks,
M


(Sam Saffron) #2

@Simon_Cossar is this related to your recent change somehow?


(Simon Cossar) #3

Not in a way that I’m seeing, but I’ll keep looking. @terraboss are there any errors in the javascript console?


(Gerhard Schlager) #4

Did you set DISCOURSE_DEFAULT_LOCALE in app.yml?
If I’m not mistaken the default locale can’t be changed when it’s set via environment variable.


(Simon Cossar) #5

That’s the only way I’ve been able to reproduce this.


(Simon Cossar) #6

Can you take a look at your app.yml file and make sure that this line is commented out?

DISCOURSE_DEFAULT_LOCALE: en

If it is not commented out, try commenting it out and running launcher rebuild app.


(Markus) #7

Originally, I’ve set DISCOURSE_DEFAULT_LOCALE: de;

Commenting it out, brought me the setting back again. Unfortunately, telling Discourse that I wanna use German as default language didn’t show any effect. That means, the logged in user has it’s correct language but not someone who isn’t logged in. These people still have to deal with English.

Any clue why?


(Simon Cossar) #8

What’s the url for your site?

I think it’s because the locale for non-logged in users is now being set by the HTTP accept-language headers for sites that allow users to select their locale.


(Markus) #9

haha, thanks, good to know :heart:

My default system language is English for a couple of reasons :wink: