Missing /shared folder inside my container

Hi Team,
I need one information, I have created new image with working discourse image, and deployed into other server. But when I entered into the container there is no /shared folder available inside the container because of that I am getting redis and postgres error. So I wanna know if I take the new image form working discourse image whether I can get the all the folder or not.

Did you include the volume mapping from the host volume to the guest volume?

When you run ./launcher rebuild app the last thing it prints is the docker command to start the container. You must include all of those environment variables, as well as the volume mapping for things to work.

4 Likes

Hi @pfaffman, Thanks for the response yes I am having the host and guest volume in app.yml. and after the build I could see the /shared folder inside my container. I was asking about the after build I have copied image and put it again so that time I missed the /shared folder inside my image container. I have manually copied the folder its working fine now, so I am gonna try with passing environment variable while starting the container, it should work for this time thanks a lot @pfaffman.

1 Like

Hey @pfaffman, I was tried to make it solved/answer post but I couldn’t get the option. Is it like only admin can give solved/answer post? if not then how to make it solved/answer the post. Could you please help me with that.
Note: /shared folder issue is working fine with the passing environment variable while starting of the container.

1 Like

Only certain categories have the solved option turned on. Glad you got it working!

3 Likes