Missing wp post images in forums (see screenshots)

I’m having this issue. I made no changes to the server:

Is this familiar to anyone where it just stops working out of the blue?

When I inspect the missing image, I see this:

Edit: I restored forum backups from as far as a week ago. No luck.

The images worked up to this morning. Do they depend on some external service besides Wordpress?

What can I check from Wordpress’ end?

Edit 2: Restoring a WP backup from last night did the trick. So reverting then will diff all files.

1 Like

Now I’m stumped. So I restored the backup that I made before reverting to yesterday’s WP backup (the one with images not working), and now the images are STILL working.

So sure what the issue was or if I will ever find the cause.

Edit: So the issue was actually still there. (Once I cleared the browser cache) I restored backups for WordPress and Discourse as old as a month ago and still have the issue. Really strange.

Edit: I notice that Discouse has excluded importing images to to the forums. Is this because it’s problematic?

For example:

2 Images…

Images removed…

How can this be achieved because this does not seem to be an issue with config or server because I restored both WP and Discourse to backups longggg before this issue and images are still missing.


Not that I have seen.


Noted. I was able to solve it. At least, I think so. I will wait a bit to confirm, then follow up next week n’ mark that thread solved if images don’t go missing again. :crossed_fingers:


I’ve slipped over these posts to here to keep the conversation grouped together. :+1:


The solution to this - I’ve since confirmed by recreating the issue and fixing again - was:
Disabling the WP-Rocket LazyLoad feature.

I’m not sure how this conflicts (not my area of expertise), which is why I was hesitant about posting as the solution, but after testing this repeatedly, I can confirm blog images will fail to load on my setup when WP-Rocket’s LazyLoad feature is enabled.

I tried FlyingPress previously and had the same issue (worse actually, because ALL images forums+blog stopped loading) so I switched to WP-Rocket.

Now WP-Rocket works with Lazyload disabled. (Lazy loading is built-in by default a lot now anyways)

Current settings which don’t affect wp-discourse images in the forums:

Leaving this here in case anyone else comes across this issue.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.