Moving from directory to subdomain


#1

Hi guys,

To make my setup less complicated per @codinghorror’s advice, and since Let’s Encrypt now support subdomains, I decided to move my discourse from foo.bar/forum to forum.foo.bar

What I did:

Changed the domain name in my app.yml, removed the folder remap from custom commands, then remapped foo.bar/forum to forum.foo.bar via discourse remap, then I rebaked posts.

The problem is this:

When I open https://forum.foo.bar/ it’s trying to fetch https://stylesheets/etc which then causes the forum display to break and I can’t really log in or change the website theme.

What can I do to fix that?

If needed, here’s the installation url: https://forum.legiochristi.com/
My app.yml: ## this is the all-in-one, standalone Discourse Docker container template ## # - Pastebin.com

Any help would be appreciated.


#2

Okay I managed to log into the admin panel but I can’t seem to change the default theme since it’s dependent on JavaScript to apply.

I also can’t download my latest backup. Is there a way to do this in command line? Either change the theme or download a backup?

Thanks.


(Joe) #3

Have you tried safe-mode?

your.site/safe-mode

#4

I’m getting this error when I try:

Chrome says it’s an invalid redirect.

Is there a way to do it through command line?


(Joe) #5

If there is, I’m not aware of it.

Perhaps someone more knowledgeable can comment on that. :sunflower:


#6

Hope so. I’ll probably nuke it and rebuild after I fetch my last backup.


(Neil Lalonde) #7

You did a rebuild too? ./launcher rebuild app


#8

Sure did.

The problem seems to be mostly that it’s trying to fetch https://stylesheets/file.css - I have no idea why that happened or how to fix it.

I see the files present in the container but they’re just not called correctly.


(Neil Lalonde) #9

It’s actually using hostname stylesheets there? Or what is the actual url?

You haven’t given enough for us to help you. Can you post your container’s yml file after removing credentials?


#10

Yes it’s actually using hostname stylesheets.

My app.yml is in the first post.

https://pastebin.com/pZPw3Ju5


(Neil Lalonde) #11

Your yml file still has the subfolder setting enabled:

DISCOURSE_RELATIVE_URL_ROOT: /

Delete that line from the file and rebuild again.


#12

amazing

i’ll try that in a sec


#13

Okay great that worked! Now the only thing left is to fix all my missing images. I’m getting a 404 on all uploaded avatars and uploaded images. Very odd.

Update:

All images return 404. I rebaked posts, recovered uploads from tombstone, and double-checked whether or not the images exist in the directories.

https://forum.legiochristi.com/uploads/default/original/1X/b104612ae2622e9ccfbb55197bb4e46059a7c171.png

this is 404

yet it exists both in /var/www/discourse/public/uploads/default/original/1X and in /shared/uploads/default/original/1X (which is symlinked successfully, therefor)

I’m at a loss here.


#14

Okay I just restored a week old backup and that didn’t help.

I also tried to chmod the uploads directory to 777

Does anyone have any ideas?