Moving to Another VPS Provider

i think there are already some discussions/collections here on meta regarding good VPS - so maybe also set a link to them?

1 Like

I see a few topics talking about providers, yes, perhaps new topics such as “VM providers in Turkey” (or any country) would be suitable here.

1 Like

I purchased the hosting and the customer care couldn’t setup Discourse. I connected to server with putty and as far as I can understand, the server needs to be active in order to install (I mean the DNS should be pointing to the new server instead of our old provider, Ocean). I will change the DNS of the nameserver this weekend and will install Discourse and update the database with my backup this weekend. I will update you about how this goes.

2 Likes

If you’re just testing it out temporarily, you can set up a name such as new.craftbeertr.com and proceed with the installation. Once it’s installed, restore a backup and make sure everything’s good.

Then when it comes time for the real switchover:

  • set both instances read-only
  • take a backup of the old instance
  • change DNS to point to the new instance
  • change the hostname on the new instance
  • restore it on the new instance

(I’m sure there’s an existing checklist for this somewhere, rather than this one I just came up with off the top of my head?)

4 Likes

Well, it’s not just testing. I planned to move yesterday but when I received the message about the DNS, I changed my mind and decided to wait a couple of days (hoping that it will resolve itself :slight_smile: ).

Thank you very much for the feedback and guidance. I thought I must point out the name in order to be able to install it. Will it be possible to modify new.craftbeer.com to craftbeer.com after the installation? Actually, I thought I should set up the new server, upload the backup and change the nameserver after everything is done. But I couldn’t and if the modification is not possible, I will have to close the forum for some time. I do not want to do is because I was planning to tell everyone after the task is complete. This DNS thing ruins my surprise!
:frowning:

I will try this in a few days. Thank you.

After you change the dns to the new server you must do a rebuild to get let’s encrypt to issue a certificate. If you rebuild without dns in place you risk hitting rate limit issues.

If you have access to the old server and it has certs then you can copy those over. See Move your Discourse Instance to a Different Server

It is, but it’s a little tricky. Change the domain name or rename your Discourse.

If you do a restore of a backup it’ll do that remapping of the name. I’d recommend using www rather than the bare domain. You can use forcewww.com to redirect to www (there are many other ways). In chrome, users can’t tell the difference between the bare domain and the www subdomain. If you want to Configure direct-delivery incoming email for self-hosted sites, using the www will make things easier if you already have incoming mail set up.

1 Like

Thank you so much for guiding me to all of these resources, @pfaffman.
:pray:

1 Like

Sorry for these never ending problems and questions but I couldn’t make this work. Setup files are in the new server and ı am getting this error:

Checking your domain name . . .
WARNING: Port 443 of computer does not appear to be accessible using hostname: new.craftbeer.com.
WARNING: Connection to http://new.craftbeer.com (port 80) also fails.

This suggests that new.craftbeer.com resolves to some IP address that does not reach this
machine where you are installing discourse.

The first thing to do is confirm that new.craftbeer.com resolves to the IP address of this server.
You usually do this at the same place you purchased the domain.

If you are sure that the IP address resolves correctly, it could be a firewall issue.
A web search for “open ports YOUR CLOUD SERVICE” might help.

Trying to learn whether this might a server firewall related issue. But “ufw status” command returns an “inactive” response.

I tried very hard for that text to explain the problem and don’t really know what else to ask.

Does new.craftbeertr.com resolve to the ip address of your server?

Is it on the internet?

For some reason trying to access you host name on ports 80 and 443 is not working.

1 Like

Actually the name points to the Digital Ocean now, but as Michael suggested, I thought I will be able to install the forum to the new server. I planned to point the nameservers to the new server after the installation, as I didn’t want to shut down the forum. I tried to install with a subdomain as suggested but I couldn’t make it work. I will point the nameserver to the new IP and then try once again.

You shouldn’t need to change your nameservers here. The only thing you ought to be changing is your A/AAAA records for the craftbeer.com and new.craftbeer.com names.

Right now they are:

craftbeer.com IN A 20.80.1.157
; new.craftbeer.com not found

You need to go to your name server control panel (you’re using ns1.domaindiscover.com. and ns2.domaindiscover.com. — seems to be https://www.tierra.net?) and add A records for new.craftbeer.com pointing at the new server IP.

3 Likes

Thank you very much for your support.
I will try this.
And it seems I can give the few people a break from the forum.
I will inform people that I will be moving things and we’ll be closed a couple of days. That seems to be the easiest way.

Thank you.

1 Like

Yeey!

image

Thank you. <3

You can test with the temporary name, but you have to have the dns set up in order to get a certificate from let’s encrypt. It doesn’t take days but under an hour. You’ll want to test the restore on your temporary subdomain before you then do it again with your real address.

1 Like

I am sorry for being such a noob.

At the beginning I thought this would be much easier. I mean, I am to hire a new server, setup forum, load the back up and change the domain address from the nameserver, but it turned a lot harder than I thought. :slight_smile:

You advised me to copy the certificates from Digital Ocean and pointed to me a document previously, @pfaffman but I am a little frustrated about that.

I told you people that I’ll have endless amount of questions and frankly speaking, I am not happy about that. Let me install to forum.craftbeer.com first, and then I’ll keep them coming. :slight_smile:

By the way, if you ever have questions about brewing at home, I’m at your service. :slight_smile:

Thank you.

1 Like

I’ve done it.

  • I installed a new forum at forum.craftbeertr.com
  • Set both instances of forum to read only mode
  • Downloaded a 2 GB zip file of the old forum
  • Restored the new forum
  • Asked a couple of people to test and they were able to log in.
  • Changed the nameserver info at Godaddy

And now waiting for the DNS info to update.

forum.craftbeertr.com (kind of) works, but craftbeertr.com still points to the old server. I am trying to make www.craftbeertr.com to point to the new server now but at the moment it returns a “This web site can not be reached” page.

I am not sure why, but the new forum started to lag after some time. I will have to deal with the problem as at the moment I can’t even log off from the admin account and it is annoyingly slow. It seems this is somehow related with me as the forum is working OK when I connect from my cell phone.

Thank you very much for all your support.

I see the nameservers are now pointing at:

Name Server: NS1.POYRAZHOSTING.COM
Name Server: NS2.POYRAZHOSTING.COM

(I’m not sure what they were before - when I checked earlier I used craftbeer.com which you wrote here)

HOWEVER these nameservers are not serving your domain:

○ → host craftbeertr.com NS1.POYRAZHOSTING.COM
Using domain server:
Name: NS1.POYRAZHOSTING.COM
Address: 141.98.115.3#53
Aliases: 

Host craftbeertr.com not found: 5(REFUSED)

this is why things are breaking.

The nameservers are merely your directory, your phone book. They are not tied to where your actual servers are located and do not generally need to be changed.

Looking at an old copy of the com. zone I have lying around, I see they were at one point:

craftbeertr.com.	172800	in	ns	ns1.digitalocean.com.
craftbeertr.com.	172800	in	ns	ns2.digitalocean.com.
craftbeertr.com.	172800	in	ns	ns3.digitalocean.com.

You can still use Digital Ocean as your name servers regardless of whether your servers are there.

At this point you either need to:

  • create a zone for craftbeertr.com at POYRAZHOSTING.COM and add the records you need there
  • switch the nameservers back to DO and update the records at DO to reflect the correct IPs for your server
2 Likes

Won’t this mean I will be paying to Digital Ocean?

They were pointing to Digital Ocean.

Thank you very much for your ongoing support. :smiling_face:

1 Like

I don’t believe they charge for DNS zones, I don’t see any mention of it on their pricing page.

2 Likes

Thank you very much for your guidance @supermathie

I changed Godaddy settings back and change nameserver info there to DO again.
Updated the IP address in DO to Poyrazhosting’s IP instead of DO’s IP and waiting for the info to update now.
Forum started working very fast in a couple of minutes time.

:pray: :vulcan_salute: :blue_heart: