Must approve own posts as staff?

approval

(Allen - Watchman Monitoring) #1

I’ve just upgraded our forum to the latest, then was able to reproduce the following:

  • View that a post is moderated
  • approve it
  • navigate to that post (*)
  • Post a reply
  • Immediately get notified that I need to approve my post.

I’m an admin/moderator on the forum in question… what site settings might be effecting this?


(Jeff Atwood) #2

Can you repro this @eviltrout?


(Robin Ward) #3

I just tried to follow these exact steps and it did not happen unfortunately.

I tried with a new topic that needed approval and a post on an existing topic that needed approval. Both times when replying to the newly approved post my post went in straight away.


(Allen - Watchman Monitoring) #4

What site settings of mine would be relevant? I’ll post them here


(Robin Ward) #5

Couldn’t hurt to take a look at any setting that has approve in it.


(Allen - Watchman Monitoring) #6

Here we go:


(cpradio) #7

What is your trust level and post count (just curious)?


(Allen - Watchman Monitoring) #8

I’m trust level 4, moderator, admin, and have 423 posts.


(cpradio) #9

What happens if you lower the approve post count to 400? Do you posts no longer need to be approved?


(Allen - Watchman Monitoring) #10

Will test that later today.


(Jeff Atwood) #13

I am really lost here. Can you give us repro steps, click by click, to cause this to happen?


Pending post, can't find where to approve
(Allen - Watchman Monitoring) #15

Here is repro on my hosted install:

  • Set must approve posts to 1000
  • As an admin, post a topic.
  • View that it needs approval

there’s a post trapped on my Consultants Discuss site now. I’ll delete it once this is confirmed.

Thanks for asking all the right questions @cpradio

EDIT - moved my initial posts about DB errors to their own topic


(Robin Ward) #16

It looks like there is no “escape hatch” for admins.

If you set the approval posts to 1000 the first 1k posts will need to be approved even if the user is an admin.

I don’t think this makes sense so I added it:

https://github.com/discourse/discourse/commit/fb7baeb7a2d3d44c81fb8dc8bc311e1af1f45bae


(Jeff Atwood) #17

Hmm, that should probably be backported to 1.3.


(Jeff Atwood) #18

(Robin Ward) #19

Backported to stable.