MySQL dep template for imports broken

Hi there, it looks like something has broken in templates/import/mysql-dep.template.yml . This process has worked consistently for me many times over the past few months. But now It fails to ./launcher bootstrap app when mysql-dep.template.yml is enabled, but it succeeds if it’s removed. This appears to be the same error too:

Looking back through the bootstrap output I wonder if the additional repo for the Debian base Docker image that Discourse uses has changed its repo key and is preventing some package from being installed into the container?

2:  actionmailer ( from /var/www/discourse/vendor/bundle/ruby/3.1.0/specifications/actionmailer-
Bundle complete! 135 Gemfile dependencies, 172 gems now installed.
Gems in the groups 'test' and 'development' were not installed.
Bundled gems are installed into `./vendor/bundle`

I, [2023-01-29T13:08:02.394673 #1]  INFO -- : > cd /var/www/discourse && echo "gem 'mysql2'" >> Gemfile
I, [2023-01-29T13:08:02.396956 #1]  INFO -- : 
I, [2023-01-29T13:08:02.397059 #1]  INFO -- : > cd /var/www/discourse && apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y libmariadb-dev
W: GPG error: stable InRelease: The following signatures were invalid: EXPKEYSIG 23E7166788B63E1E Yarn Packaging <>
E: The repository ' stable InRelease' is not signed.
I, [2023-01-29T13:08:04.131013 #1]  INFO -- : Get:1 bullseye InRelease [116 kB]
Get:2 bullseye-security InRelease [48.4 kB]
Get:3 bullseye-updates InRelease [44.1 kB]
Get:4 bullseye-backports InRelease [49.0 kB]
Get:5 stable InRelease [17.1 kB]
Get:6 bullseye/main amd64 Packages [8,183 kB]
Get:7 bullseye InRelease [4,586 B]
Get:8 bullseye-pgdg InRelease [91.7 kB]
Get:9 bullseye-security/main amd64 Packages [216 kB]
Get:10 bullseye-updates/main amd64 Packages [14.6 kB]
Get:11 bullseye-backports/main amd64 Packages [384 kB]
Err:5 stable InRelease
  The following signatures were invalid: EXPKEYSIG 23E7166788B63E1E Yarn Packaging <>
Get:12 bullseye/main amd64 Packages [774 B]
Get:13 bullseye-pgdg/main amd64 Packages [268 kB]
Reading package lists...

I, [2023-01-29T13:08:04.131367 #1]  INFO -- : Terminating async processes
I, [2023-01-29T13:08:04.131403 #1]  INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 42
I, [2023-01-29T13:08:04.131434 #1]  INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 103
103:signal-handler (1674997684) Received SIGTERM scheduling shutdown...
2023-01-29 13:08:04.131 UTC [42] LOG:  received fast shutdown request
2023-01-29 13:08:04.133 UTC [42] LOG:  aborting any active transactions
2023-01-29 13:08:04.134 UTC [42] LOG:  background worker "logical replication launcher" (PID 51) exited with exit code 1
2023-01-29 13:08:04.134 UTC [46] LOG:  shutting down
2023-01-29 13:08:04.154 UTC [42] LOG:  database system is shut down
103:M 29 Jan 2023 13:08:04.205 # User requested shutdown...
103:M 29 Jan 2023 13:08:04.205 * Saving the final RDB snapshot before exiting.
103:M 29 Jan 2023 13:08:04.207 * DB saved on disk
103:M 29 Jan 2023 13:08:04.207 # Redis is now ready to exit, bye bye...

Pups::ExecError: cd /var/www/discourse && apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y libmariadb-dev failed with return #<Process::Status: pid 451 exit 100>
Location of failure: /usr/local/lib/ruby/gems/3.1.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "cmd"=>["echo \"gem 'mysql2'\" >> Gemfile", "apt-get update && DEBIAN_FRONTEND=noninteractive apt-get install -y libmariadb-dev", "su discourse -c 'bundle config unset deployment'", "su discourse -c 'bundle install --no-deployment --path vendor/bundle --jobs 4 --without test development'"]}
bootstrap failed with exit code 100
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

Duplicate of