New installation not appearing at domain name or IP address

Hi, I have tried to install Discourse multiple times over the past few days to a DigitalOcean droplet using the basic “under 30 minutes” install instructions, but every time the installation finishes and I go to the domain I set up or the IP address of the droplet, nothing shows up: at the domain I get the error DNS_PROBE_FINISHED_NXDOMAIN and at the IP address I get ERR_CONNECTION_REFUSED.

I have searched this forum over and over for solutions and I gather there is probably some issue with the SSL cert and Let’s Encrypt, but I can’t seem to find a solution in previous threads that works. I have tried changing my subdomain to something else in case Let’s Encrypt was refusing to issue a cert for the previous one due to too many requests; I tried destroying my droplet and creating a new one with a different IP; nothing is working.

Chances are I’m making some kind of stupid mistake. Am I correct in understanding that all I’m supposed to do to make Let’s Encrypt work is put in my email address during setup? Is there some step I’m missing? I’m relatively new to all this command line stuff (hence why I’m following the basic installation instructions).


hi @flyrefi :wave: welcome :slight_smile:
hmmm you may be getting rate limited by let’s encrypt if you’ve been making multiple setup attempts, although I think the standard install should prevent that to some extent. Can you post any more error log messages? also maybe flush the DNS cache.


Hi, thanks. Flushing the DNS cache didn’t do anything.

Discourse Doctor says “Discourse version at discourse.[mydomain].org: NOT FOUND” and “Discourse version at localhost: NOT FOUND,” but the Docker Info section says “Discourse container app is running” and the Mail Test sent a test email to my email address as expected.

Anywhere else I should look for errors?

One more thing: could this error have anything to do with me trying to install Discourse on a server with 1 GB RAM? I’m trying to set up a small private forum for a handful of people and I figured the extra RAM wouldn’t be needed but if there’s a chance that could be causing all this I’ll upgrade.

1 Like

Maybe the DNS records you created for your domain are not configured correctly, or have not yet propagated. I’m basing that on this post: Bizarre installation problem re: specific domain name - #2 by david.

Try running the following from a terminal on your computer, with the domain name you are using for your site substituted for


If you can share the output here, someone may be able to spot an issue.


The 1g of ram should be fine. A company I help with originally had a bare minimum vps with 20g of space. The next tier up or 2 is generally better. However you might be fine depending on scale.

They ignored my warnings of an impending crash due to lack of space I reported for over a months could no longer ssh in and upgrade.

Took them a week or two to get it fixed after the crash.

as @simon said it sounds like a setup issue in your dns records.

1 Like

Ugh! It was a stupid mistake after all, thanks for pointing me in the right direction. I had written the whole address (“discourse.[mydomain].com”) as the host for the A record, but NameCheap requires you to just put the subdomain (“discourse”). Changing that and re-doing ./discourse-setup one last time did the trick.

1 Like