New private message button missing

In the messaging center (on which you see your inbox, sent items, etc) there is no button to create a “new message”. Only for moderator / admins this button exists.

On the other side, the same user is able to create a new message, if he/she clicks on the avatar of a user and selects “new message” on the user card.

Can someone please let me know which setting I need to change?

1 Like

You should find & change this setting:

min trust to send messages

1 Like

Are you referring to this page?

If so there should be a new message button in blue above inbox:


@Thomas_G: The “min trust level to send messages” is set to TL0. So, this can not be the reason.
@Stephen: Yes, the “new message” button above “inbox” is missing. But, as I said, on the user card the “message” button occurs which then can be used to send a message. Its weird.
I would have a look at the code if I would find the section to look at :slight_smile:

I have discourse-encrypt enabled. I disabled the plugin but the button is still missing.


One more addition:

  • The button “New message” above inbox exists if the user is a moderator
  • All users are “SAML” users.
1 Like

Oh. This was a evil one. Sorry to everyone!

The issue was: the “system” user disabled the option to receive private messages.

The “New button” is guarded by “can_send_private_message?(Discourse.system_user)” -> if you disable that the system user can receive private messages -> the button is gone.

If you click directly on the “message” button on the User Card of a user, the guard is of course different as it will then verify the target user directly.

Thanks to everyone. Did I already mention, that open source code is beautiful?


Nice spelunking :+1:

How did that happen? :thinking:

1 Like

Well, someone (myself?) changed this value some week/month ago?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.