Nginx not binding to ipv6 address using the Discourse Docker image

I am not sure if this is a bug or if I did something, I don’t think I did and I checked the templates and they are configured to listen on the ipv6 address. This has been happening since January 7 at 4:51 AM UTC according to our monitoring. IPv4 access is still okay.

Did I do something weird?

I’d say yes, as my test site on Digital Ocean is listening on IPv6 just fine.

That’s the weird part, I didn’t change anything. Did you configure or change Docker config files in any way?

No, plain old Digital Ocean install using the guide.

Is your droplet IPv6 enabled?

It WAS working and then stopped suddenly – so I’m confused as hell – lemme try and rebuild and report back.

Our Discourse instance is hosted on the (soon to be decomissioned) OpenStack Rackspace cloud platform.

I can’t seem to figure this out and it’s driving me nuts – rebuilding did nothing

Do the debugging steps.

Start another software listening to a free port on IPv6 and try to connect to it from elsewhere. Does it work?


OpenSSH is listening on IPv6

You might try using nestat and lsof commands to see what (if anything) is officially listening on your 80/443 ports for ipv6. See How to check for open ports on Linux – Linux Hint for examples.