No `force_https` setting?

Has the force_https setting been removed? Or is does it not show up if certain templates are used. Here are the templates I’m using:

templates:
  - "templates/postgres.template.yml"
  - "templates/redis.template.yml"
  - "templates/web.template.yml"
  - "templates/cloudflare.template.yml"
  - "templates/web.ssl.template.yml"  # https
  - "templates/web.letsencrypt.ssl.template.yml"  # https
  # - "templates/web.ratelimited.template.yml" # not needed 

I don’t think so. I see no changes around force_https and I can still see the setting :thinking:


`

I think there is some magic that hides it if you meet certain criteria:

Without finding the code, I think what happens is that if you have a certificate, DISCOURSE_FORCE_HTTPS gets set to true, so it’s hidden from the UX.

4 Likes

I was looking for this the other day. Is it this bit:

6 Likes

That’s it! The other way to get stuff into config/discourse.conf is setting an ENV variable, which results in something writing those out to that file just like that.

3 Likes