No Profile Header or User Card Background in /preference/profile?

It seems I can’t upload profile banners on my instance anymore…

Here’s what I have at /preferences/profile

This parameter is checked:

I’ve checked in safe mode and I still have the problem. :confused:

Any thoughts?

This is not reproducing on meta…

Does the user have the right trust level? Are there any non-official plugins installed?

I’m a staff user and it doesn’t show. Also, I’ve tried safe mode with no plugins :confused:

Safe mode does not disable server side changes. I recommend removing 3rd party plugins and trying again. Meta is running tests-passed and I am not seeing the issue here.

Could I ask which theme your site is using?

I’ve seen some do… strange things. (Even the team’s.)

I’ve just signed up to the forum in your profile (if this is the instance in question) and I can upload a profile header and usercard background:

I’m using Safari/iPhone if that makes a difference?


Good to know! Will def try that.

Default light/dark with custom CSS.

Yes, that’s the one. Well I’ll be damned. I can’t see them when I’m logged in as an admin! I’ve tried inspecting the elements and I couldn’t find the id=“profile-background-uploader”.

Will try to load without plugins to see if that’s what’s up! Thank you all for your help. :slight_smile:

1 Like

Huh. That’s interesting.

If you don’t mind me asking, do the options show for you here on Meta?

Reason I ask is, while it’s not impossible it’s a Discourse plugin issue, if it was, I would expect it to affect everyone. Checking your preferences here on Meta would clarify whether it’s a web browser setting / extension that’s responsible. Only asking as it’s quick to check & it would be good to rule them out.

Admins can also have trust levels and this can sometimes in rare cases muck stuff up. Did you set yours to Trust level 4?