No user preferences updating on my site

Users are unable to change their about section in my forum. When they press save it says saved, but refreshing just clears this. Unable to reproduce on Meta. Able to reproduce when I change my bio or change someone else’s. I checked error logs, nothing showing up regarding this. Is there any place where I can begin debugging something like this? I don’t know how long this has been here only after a user reported it today.

I’m going to guess this is tied to the issue where I can’t change category watching settings on your forum as well.

Anyways, have you tried safe mode?

No have not, will try

Tried safe mode, issue persists. recorded vid:

Bump, I checked dev tools while I try it, the request is being sent correctly but the response just contains old values.

Sent data:

Received data:

I dont even know what caused this, any help please? I can even pay up to $50 for this it’s being site breaking for us.

Update: this is not just about me but any setting in preferences doesn’t update.

If you want to make this a paid gig you should post in marketplace :+1:

Done, I will use Replit Bounties to pay. Here is the Bounty for $50 Discourse User Preferences not Updating - Replit

For some reason, themes are still changeable via user preferences. Thanks to @Firepup650 for pointing that out in my forum.

I have no clue how it’s working now, I removed a crap ton of unused plugins from my forum and it magically started working (just disabling them made no difference). TIL.

It’s very rare, but it happens that plugins can cause issues even when disabled. I recall at least one occurrence of this behavior (which was fixed in the plugin).


I’ve moved it back over to support as you’ve managed to solve it yourself. :+1:

Safe mode only disables certain elements of the plugins, though generally the pieces which are most likely to cause issues. In some cases they would need to be completely removed from your app.yml. It’s generally good practice to remove any unused plugins, especially third-party ones, if you’re not using them - and particularly if you’re experiencing difficulties that cannot be replicated here on Meta or on another test site.


Yeah, it’s a kind of bad habit that devs get into sometimes, that disabling a plugin doesn’t always disable a plugin fully.

The only guarantee is to remove it from your build.


Ahha, found the culprit, it was a version of the Auto Email Activation plugin. Removing it from app.yml fixes the issue. I got Discourse running locally and will try to fix it myself soon.

I know it’s not reccomennded to use, but I had really good luck using it basically doubled our active users when accounts are automatically activated. A lot of our users are teenagers in school who use their school emails, and I guess a lot of schools have strict blocking filters which block verification emails from getting through (doesn’t even show in spam)

I want to learn Discourse Plugin development and if I do, that will be my first maintained plugin for the community to use. Will update soon.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.