User preferences page leads to 404


(Cheng Zheng) #1

Thanks!

also, I am not sure why my “Preferences” get 404

Before click

After click “Preferences”

I didn’t change original codebase, so I am not sure why this happen

Terminal Screenshot

Above blue line is refresh http://localhost:3000/u/guokrfans/notifications
Below blue line is click “Preferences”


How do I install a Theme or Theme Component?
(Joe) #2

Try to disable any plugins you have in your-site.com/safe-mode


(Cheng Zheng) #3

I would try it now, thanks!


(Cheng Zheng) #4

http://localhost:3000/safe-mode

Click “Enter Safe Mode” it jump into homepage localhost:3000

Click top right corner and enter profile

Click “Preferences” got 404


(Cheng Zheng) #5

If you want to,
we can do “TeamViewer”(or some other tool)
and let you remotely control my laptop


(Joe) #6

I’m not exactly sure what’s going on here, So I won’t be able to help much.

I’m sure someone else will pick this up though.


(Cheng Zheng) #7

understood, Thanks for spend your time helping me on this issue!
Thank you very much!


(Cheng Zheng) #8

I fixed the problem (2018-4-29)

(on my local Macbook Pro with localhost:3000)

I download discourse codebase again with

git clone https://github.com/discourse/discourse.git original_discourse

and then

bundle exec rake db:migrate
rails s

Now User Preferences Page is ok

I am not quite sure what’s the problem with the other discourse folder I have.
It could cause by theme or plugin that I install. maybe.

Anyway, now problem gone

— Update —
I think sidekiq is part of the problem, I didn’t run sidekiq at my local machine, and got 404
after I run sidekiq the 404 problem gone