No username check prompt when logging in with SSO

Thanks for that clarification. We have one problem with our SSO in terms of usernames. When somebody registers via our SSO he automatically gets logged-in and there is no prompt that asks him if the username is ok and if he wants to change it like in this forum here

I couldn’t find this settings in our discourse. It should work like here when I created my account with Google login.

With the Discourse custom SSO protocol, it’s been assumed that the user can manage all relevant account aspects, including username, in the external auth provider. We recently added the external auth skip create confirm setting to go in the other direction for non-SSO authenticators.

Another option is to uncheck sso overrides username, and users will be able to change their own username after logging in.

4 Likes

We want to use Discourse custom SSO, but we don’t otherwise have the concept of user names. Is it possible to force this dialog (even in code)? Right now we get a bunch of user1245, which is not optimal.