Not receiving initial admin email verification. Install issue?

email

#1

Totally new at this stuff, but have been wanting to test Discourse for a while now. Today I finally pulled the trigger and got myself an account at Digital Ocean. I installed a Discourse droplet but am not receiving the email verification for the admin account to login.

I have ‘destroyed’ the droplet and re-installed Discourse about 7 - 10 times today, each time trying different settings for the email setup, but nothing has worked. I have tried using both the SSL and non-SSL server and port settings, but neither have worked. I have tried different hostnames, too.

Am I supposed to install a mail server on Ubuntu?

Just in case I am doing something wrong, here’s how I’m installing Discourse:

  • New droplet
  • Hostname “forum” (without the quotes), also used forum.domainname.com, and test.domainname.com, among others.
  • $20 plan, Toronto server
  • Select Image > Applications > Discourse
  • Available Settings: Backups & IPV6

Thoughts?


(Régis Hanol) #2

I think it’s a Digital Ocean issue. @ryan2 any idea what’s wrong here?


(ryan2) #3

Hey. Sorry you’re having trouble with the image. What service are you using for SMTP? Our testing was done primarily with mandrill. Also, are you otherwise able to send email messages from droplets on your account? If you’re not sure, I’d recommend opening a ticket with our support team. Some accounts may have an SMTP block by default based on a number of variables. if this is the case, support can confirm it and get the block lifted for you.


(Jeff Atwood) #4

Warning, we get so many email support requests – there are many, many, many ways to screw up your SMTP settings so that email doesn’t work. I recommend you strictly follow our email troubleshooting document in the howto section here.

Worst case scenario, buy a $99 install from us and we’ll set it up for you guaranteed to work, including a Mandrill reseller code that gives you an email account worth well in excess of $99…