Polls disabled caused 500 error


#1

I just performed a update to the latest version of discourse (test-passed). After that update, I get an error message when accessing any topic in the forum. Something that translates to: Sorry, we couldn’t load the topic – probably due to a connection error. Please try again.

The production logs keeps showing

Completed 500 Internal Server Error in 439ms (ActiveRecord: 425.3ms)
LocalJumpError (unexpected return)
/var/www/discourse/lib/plugin/instance.rb:188:in `block (2 levels) in topic_view_post_custom_fields_whitelister'

for almost all requests.

Any help would be appreciated.

Rebuilding the app did not help.


(David Taylor) #2

What plugins do you have installed?


#3

docker_manager
discourse-solved
discourse-cakeday


(David Taylor) #5

Do you have any other plugins installed, but disabled?


#6

That was the list from app.yml. I don’t know any other place where plugins could be specified.


(David Taylor) #7

I have just created a fix, it will take a few minutes to reach tests-passed

However, none of those three plugins make use of this particular part of the code, so I am unsure why the error is occurring for you.

@some-user it’s now in tests-passed, so please try updating again and see if that fixes the issue.


#8

Thanks for the notification :slight_smile: Update is installed, problem solved. Amazingly quick support. :star_struck: Thank you very much!

If you want to look into that and I can do anything to support, let me know. But as the patient is alive again…


(David Taylor) #9

Good to hear :slight_smile:

I have one idea - do you have the built-in “polls” plugin disabled? (check the poll enabled site setting). That would explain it.


#10

Yes, it is was. :relieved:


(David Taylor) #11

Mystery solved! :male_detective:

(now that the bug is fixed, it is perfectly safe to leave it disabled if you want)


(David Taylor) #12