Posts not being flagged as read due to CSS changes

Are there issues with plugins or customizations there that could be interfering? I am not aware of any issues with read state on any other Discourse sites we host, across hundreds…

The first thought I had was “whispers strikes again”

IF it is only the rare topic

ELSE if all topics then it is something else going on.

Hi Jeff, thanks for the reply. Honestly, I don’t think I would know as I don’t have the level of access to check. I think you are a member on the forum actually, but appreciate you don’t have time to make person house calls as it were for these things.

There were some minor changes made I believe to the header/logo recently, which I think have been reverted, but I think that was primarily a CSS thing, sorry, I don’t really know.

If this issue has occurred/been reported on the other hosted sites though it does suggest something specific about this one. I can ask the questions back to the admins but obviously, being piggy-in-the-middle, may lead to me not really asking the right questions (in either direction). So far only a small number of people have noticed it, but as a moderator it’s a bit of a p.i.t.a for me (selfish I know!)…

Is it specific to certain topics? Are whispers being used, as @Mittineague pointed out?

Hi @Mittineague, from my view, it appears to be anything I respond to. Originally I had about 4 unread topics, this count has been growing steadily.

If you are a moderator you’d be able to see whispers. Only normal (non-staff) users can’t see whispers. Whispers is a staff function.

Doesn’t appear to be specific to any individual topics, I can recreate it I believe on any. I can test that in a moment, hmm, actually I don’t know if I can, as I guess I would need someone else to respond wouldn’t I (rather than me replying to my own topic to trigger an unread message).

I don’t know what whispers are, but if it’s anything outside of the standard replying to a post I don’t believe so, no.

Can you tell me what identifies a post as a whisper? e.g. does it state “whisper” or is it a different colour or anything like that?

You can try it yourself as a staff member. In the reply area, click the gear icon, then toggle whisper. Try it in the staff category first :wink:

Ok, will do - I will go take a look at that now.

Here’s a small screenshot by the way of what I see…


…the blue/grey counts etc, and these are posts from all over the forum so I don’t think this is likely to be whispers - too many by too many different people for that to be the case.

If you recently changed your Preference settings to
track - immediately
and you don’t read until the end of a topic that could do it

if recently changed
new - haven’t seen yet
you may end up with a lot of New

Do you have any local browser customizations or extensions? Can you try in a different web browser, one you do not normally use?

I was using Chrome, I don’t have anything specific installed that I am aware of - nothing that I wasn’t using before I started noticing the issue anyway. I have just fired up Edge and had the same experience with that, e.g. clicked on Unread - clicked on the first post in the list, scrolled to the bottom of all the posts, clicked back (via the forum links, not the back button), the unread count remained the same.

I’ve not changed any of my preferences, not that I am aware of, I viewed the a day or so ago when someone else reported the same issue. Here’s a screen shot;

Looking at the selected option, I take it that doesn’t mean Always consider a topic new when it was posted in the last two days, e.g. regardless of whether I have read it or not?

Just made a post, then went to reply to it, I have no options anywhere regarding whispers.

I strongly suspect some CSS or HTML (or JavaScript, if you have any) customization is interfering with read state.

I’m going to disable your customizations temporarily as I am quite confident this is the issue.

Admin, Customize, HTML/CSS, Links, “enabled” checkbox set to off.

Ok - as I said I’m not an admin, so I don’t think I would be able to see the settings.

Shall I close/re-open the browser and see what happens?

Update

Looks like this must have been the case. I just refreshed the page, went back in and the list of unread items was slightly different. I clicked on the first topic, it took me to the last post, I used the links to navigate back to the summary of topics and the count had reduced by 1 for the unread items.

Could you change the settings back, I will then point the team to this thread. Is that ok?

(had to put this here as I’ve reached the max number of replies for a new user!)

2 Likes

Sorry, I forgot this is not enabled by default. Admin, Site Settings, “enable whispers”. Just be aware it can cause topics to look unread by normal users, but that doesn’t apply to you, as you are a moderator. sorry for the false alarm.

It’s not a problem, I appreciate the help/time you are giving the issue for me :slight_smile:

Sounds like it is not the case here, but I’d like to point out certain user options can produce bogus unread counts, too:

2 Likes