Prevent Create New Account dialog

With JWT login, I end up at…

My auth service manages users and only JWT login in enabled. I don’t want users having different usernames between the discourse and the platform. How do I prevent this screen from showing up?

Disable all the login options except the one that You want to keep. That’ll do the trick.

2 Likes

In particular, disable local logins.

1 Like

If any social logins are enabled, modal still shows up I guess?

1 Like

I tried checking / unchecking various settings related to login, still shows up. JWT is the only login method enabled.

Is this related to discourse-jwt or more of a general form?

In case it escaped your notice, this is the registration form, not a login form.

When discourse isn’t using internal auth, either of those should be disabled.

But this can be specific to JWT as I’ve never personally tried using it.

1 Like

Everything else is disabled. Probably something to do with GitHub - discourse/discourse-omniauth-jwt: An OmniAuth strategy that uses JSON Web Token for Single Sign-On then.

Yes the create account dialog will appear even if JWT is the only login method. We need to collect extra data (username and email) so that Discourse functions correctly. You can pre-fill the fields by supplying the values as “name” and “email” claims in the token.

3 Likes

These will always be available in the JWT and I prefill them. I want to disallow editing of these fields.

Or better yet, not show the form at all.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.