Problem in development Installation

When I reach To “Bundle Install” Then This Appeares

An error occurred while installing xorcist (1.1.2), and Bundler cannot continue.

In Gemfile:
  xorcist

What Will I do now

Generally this kind of error means there is a linux package that needs to be installed before ruby can install the gem for it. See xorcist | RubyGems.org | your community gem host

1 Like

when i use this comand sudo apt install xorcist
then it shows this

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package xorcist
1 Like

Try to run sudo apt update and then again sudo apt install xorcist

1 Like

similar error continues even after running this comand sudo apt update then sudo apt install xorcist

hi Gaurav;
the xorcist gem does not need any external dependencies, which would usually be helped by installing packages through the OS like Daniela said.

Rather, there seems to be a more general issue installing gems (lack of space, permissions, etc).
Can you show more of the error message when it happens?

hello @leonardo
first This Comand Bundle install
then it shows this

Fetching gem metadata from https://rubygems.org/.........
Using rake 13.0.6
Using concurrent-ruby 1.1.9
Using minitest 5.15.0
Using zeitwerk 2.5.1
Using builder 3.2.4
Using erubi 1.10.0
Using aws-partitions 1.516.0
Using crass 1.0.6
Using jmespath 1.4.0
Using ember-source 2.18.2
Using execjs 2.8.1
Using coderay 1.1.3
Fetching debug_inspector 1.1.0
Fetching msgpack 1.4.2
Fetching racc 1.6.0
Using mini_mime 1.1.2
Using uniform_notifier 1.14.2
Using bundler 2.2.26
Using ast 2.4.2
Fetching cbor 0.5.9.6
Using public_suffix 4.0.6
Using certified 1.0.0
Using chunky_png 1.4.0
Using rack 2.2.3
Using connection_pool 2.2.5
Using aws-eventstream 1.2.0
Using ipaddr 1.2.3
Fetching cppjieba_rb 0.3.3
Using rexml 3.2.5
Using diff-lcs 1.5.0
Fetching byebug 11.1.3
Using diffy 3.4.0
Using method_source 1.0.0
Using thor 1.1.0
Using discourse-ember-source 3.12.2.3
Using discourse-fonts 0.0.9
Using colored2 3.1.2
Using docile 1.4.0
Using regexp_parser 2.2.0
Using email_reply_trimmer 0.1.13
Using excon 0.89.0
Using exifr 1.3.9
Using fabrication 2.23.1
Using fakeweb 1.3.0
Using faraday-em_http 1.0.0
Using faraday-em_synchrony 1.0.0
Using faraday-excon 1.1.0
Using faraday-httpclient 1.0.1
Using faraday-net_http 1.0.1
Using faraday-net_http_persistent 1.2.0
Using faraday-patron 1.0.0
Using faraday-rack 1.0.0
Using multipart-post 2.1.1
Using ruby2_keywords 0.0.5
Fetching fast_blank 1.0.1
Using literate_randomizer 0.4.0
Fetching fast_xs 0.8.0
Installing racc 1.6.0 with native extensions
Installing byebug 11.1.3 with native extensions
Installing debug_inspector 1.1.0 with native extensions
Installing fast_blank 1.0.1 with native extensions
Installing cbor 0.5.9.6 with native extensions
Installing fast_xs 0.8.0 with native extensions
Installing msgpack 1.4.2 with native extensions
Using fastimage 2.2.6
Fetching ffi 1.15.4
Using fspath 3.1.2
Using guess_html_encoding 0.0.11
Using hana 1.3.7
Using hashdiff 1.0.1
Using hashie 4.1.0
Using highline 2.0.3
Using hkdf 0.3.0
Using htmlentities 4.3.4
Using http_accept_language 2.1.1
Using image_size 3.0.1
Using in_threads 1.5.4
Using progress 3.6.0
Fetching gc_tracer 1.5.1
Fetching json 2.6.1
Installing gc_tracer 1.5.1 with native extensions
Installing json 2.6.1 with native extensions
Using uri_template 0.7.0
Using jwt 2.3.0
Using libv8-node 16.10.0.0 (x86_64-linux)
Using rb-fsevent 0.11.0
Using logstash-event 1.2.02
Using logster 2.10.1
Using lru_redux 1.1.0
Fetching lz4-ruby 0.3.3
Fetching kgio 2.11.4
Installing lz4-ruby 0.3.3 with native extensions
Installing kgio 2.11.4 with native extensions
Installing ffi 1.15.4 with native extensions
Using maxminddb 0.1.22
Using memory_profiler 1.0.0
Using redis 4.5.1
Using mini_sql 1.1.3
Using mocha 1.13.0
Using multi_json 1.15.0
Using multi_xml 0.6.0
Using mustache 1.1.1
Fetching nio4r 2.5.8
Using oauth 0.5.8
Using optimist 3.0.1
Using parallel 1.21.0
Installing nio4r 2.5.8 with native extensions
Using r2 0.2.7
Using rainbow 3.0.0
Fetching raindrops 0.20.0
Using rchardet 1.8.0
Fetching pg 1.2.3
Fetching oj 3.13.2
Installing raindrops 0.20.0 with native extensions
Fetching rinku 2.0.6
Using rotp 6.2.0
Using rqrcode_core 1.2.0
Using rspec-support 3.10.3
Using rtlit 0.0.5
Using ruby-progressbar 1.11.0
Using unicode-display_width 2.1.0
Installing pg 1.2.3 with native extensions
Fetching ruby-prof 1.4.3
Installing oj 3.13.2 with native extensions
Installing rinku 2.0.6 with native extensions
Installing ruby-prof 1.4.3 with native extensions
Using rubyzip 2.3.2
Using tilt 2.0.10
Using simplecov-html 0.12.3
Using sshkey 2.0.0
Fetching stackprof 0.2.17
Using simplecov_json_formatter 0.1.3
Using test-prof 1.0.7
Fetching unf_ext 0.0.8
Installing stackprof 0.2.17 with native extensions
Fetching xorcist 1.1.2
Installing xorcist 1.1.2 with native extensions
Installing unf_ext 0.0.8 with native extensions
Using yaml-lint 0.0.10
Using i18n 1.8.11
Using tzinfo 2.0.4
Using barber 0.12.2
Using ember-data-source 3.0.2
Using uglifier 4.2.0
Using mail 2.8.0.edge from https://github.com/discourse/mail.git (at main@5b700fc)
Using parser 3.0.3.2
Using addressable 2.8.0
Using rack-test 1.1.0
Using better_errors 2.9.1
Using sprockets 3.7.2
Using request_store 1.5.0
Using message_bus 3.3.8
Using rack-mini-profiler 2.3.3
Using rack-protection 2.1.0
Using aws-sigv4 1.4.0
Fetching openssl 2.2.1
Installing openssl 2.2.1 with native extensions
Using crack 0.4.5
Using rss 0.2.9
Using ecma-re-validator 0.3.0
Using faraday 1.8.0
Using mock_redis 0.29.0
Using omniauth 1.9.1
Fetching mini_racer 0.5.0
Using image_optim 0.31.1
Using webpush 1.1.0
Using logstash-logger 0.26.1
Using sidekiq 6.3.1
Using redis-namespace 1.8.1
Using parallel_tests 3.7.3
Using rqrcode 2.1.0
Using rspec-core 3.10.1
Using rspec-expectations 3.10.1
Using rspec-mocks 3.10.2
Using simplecov 0.21.2
Using activesupport 6.1.4.1
Using faker 2.19.0
Using rubocop-ast 1.15.0
Using aws-sdk-core 3.121.2
Using css_parser 1.11.0
Using ember-handlebars-template 0.8.0
Using json-schema 2.8.1
Using webmock 3.14.0
Using json_schemer 0.2.18
Using oauth2 1.4.7
Using pry 0.13.1
Using omniauth-oauth 1.2.0
Using globalid 1.0.0
Using activemodel 6.1.4.1
Using bullet 7.0.0
Using discourse_dev_assets 0.0.3
Using rspec 3.10.0
Using shoulda-matchers 5.1.0
Using mini_scheduler 0.13.0
Installing mini_racer 0.5.0 with native extensions
Installing cppjieba_rb 0.3.3 with native extensions
Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/racc-1.6.0/ext/racc/cparse
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-1vjcebw.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/racc-1.6.0 for inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/racc-1.6.0/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing racc (1.6.0), and Bundler cannot continue.

In Gemfile:
  actionmailer was resolved to 6.1.4.1, which depends on
    actionpack was resolved to 6.1.4.1, which depends on
      actionview was resolved to 6.1.4.1, which depends on
        rails-dom-testing was resolved to 2.0.3, which depends on
          nokogiri was resolved to 1.12.5, which depends on
            racc


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

current directory:
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/debug_inspector-1.1.0/ext/debug_inspector
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-2tbyeo.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/debug_inspector-1.1.0 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/debug_inspector-1.1.0/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing debug_inspector (1.1.0), and Bundler cannot continue.

In Gemfile:
  binding_of_caller was resolved to 1.0.0, which depends on
    debug_inspector


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/msgpack-1.4.2/ext/msgpack
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-12s1161.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/msgpack-1.4.2 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/msgpack-1.4.2/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing msgpack (1.4.2), and Bundler cannot continue.

In Gemfile:
  bootsnap was resolved to 1.9.3, which depends on
    msgpack


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/byebug-11.1.3/ext/byebug
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-14eb4fy.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/byebug-11.1.3 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/byebug-11.1.3/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing byebug (11.1.3), and Bundler cannot continue.

In Gemfile:
  pry-byebug was resolved to 3.9.0, which depends on
    byebug


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/cbor-0.5.9.6/ext/cbor
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-bjcvwh.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/cbor-0.5.9.6 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/cbor-0.5.9.6/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing cbor (0.5.9.6), and Bundler cannot continue.

In Gemfile:
  cose was resolved to 1.2.0, which depends on
    cbor


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/fast_blank-1.0.1/ext/fast_blank
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-1ou96k.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/fast_blank-1.0.1 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/fast_blank-1.0.1/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing fast_blank (1.0.1), and Bundler cannot continue.

In Gemfile:
  fast_blank


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/fast_xs-0.8.0/ext/fast_xs
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-jgca9p.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/fast_xs-0.8.0 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/fast_xs-0.8.0/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing fast_xs (0.8.0), and Bundler cannot continue.

In Gemfile:
  fast_xs


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/gc_tracer-1.5.1/ext/gc_tracer
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-15spdm.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/gc_tracer-1.5.1 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/gc_tracer-1.5.1/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing gc_tracer (1.5.1), and Bundler cannot continue.

In Gemfile:
  gc_tracer


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/json-2.6.1/ext/json/ext/generator
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-f3w8f.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/json-2.6.1 for inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/json-2.6.1/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing json (2.6.1), and Bundler cannot continue.

In Gemfile:
  json


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/kgio-2.11.4/ext/kgio
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-yq4a8z.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/kgio-2.11.4 for inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/kgio-2.11.4/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing kgio (2.11.4), and Bundler cannot continue.

In Gemfile:
  unicorn was resolved to 6.0.0, which depends on
    kgio


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/lz4-ruby-0.3.3/ext/lz4ruby
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-1apna7b.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/lz4-ruby-0.3.3 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/lz4-ruby-0.3.3/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing lz4-ruby (0.3.3), and Bundler cannot continue.

In Gemfile:
  lz4-ruby


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/nio4r-2.5.8/ext/nio4r
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-1o1ivhp.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/nio4r-2.5.8 for inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/nio4r-2.5.8/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing nio4r (2.5.8), and Bundler cannot continue.

In Gemfile:
  puma was resolved to 5.5.2, which depends on
    nio4r


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/pg-1.2.3/ext
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-wh1fgc.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/pg-1.2.3 for inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/pg-1.2.3/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing pg (1.2.3), and Bundler cannot continue.

In Gemfile:
  pg


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/raindrops-0.20.0/ext/raindrops
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-hj58t1.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/raindrops-0.20.0 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/raindrops-0.20.0/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing raindrops (0.20.0), and Bundler cannot continue.

In Gemfile:
  unicorn was resolved to 6.0.0, which depends on
    raindrops


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/rinku-2.0.6/ext/rinku
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-11brm5t.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/rinku-2.0.6 for inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/rinku-2.0.6/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing rinku (2.0.6), and Bundler cannot continue.

In Gemfile:
  rinku


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/ruby-prof-1.4.3/ext/ruby_prof
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-frewex.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/ruby-prof-1.4.3 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/ruby-prof-1.4.3/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing ruby-prof (1.4.3), and Bundler cannot continue.

In Gemfile:
  ruby-prof


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/stackprof-0.2.17/ext/stackprof
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-j51xct.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/stackprof-0.2.17 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/stackprof-0.2.17/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing stackprof (0.2.17), and Bundler cannot continue.

In Gemfile:
  stackprof


Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    current directory: /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/xorcist-1.1.2/ext/xorcist
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-85-1yx616e.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/gems/xorcist-1.1.2 for
inspection.
Results logged to
/home/gauravmonga/discourse/vendor/bundle/ruby/2.7.0/extensions/x86_64-linux/2.7.0/xorcist-1.1.2/gem_make.out

  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:97:in `run'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:48:in `block in build'
  /usr/lib/ruby/2.7.0/tempfile.rb:291:in `open'
  /usr/lib/ruby/2.7.0/rubygems/ext/ext_conf_builder.rb:30:in `build'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:167:in `block in build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `synchronize'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:163:in `build_extension'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:208:in `block in build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `each'
  /usr/lib/ruby/2.7.0/rubygems/ext/builder.rb:205:in `build_extensions'
  /usr/lib/ruby/2.7.0/rubygems/installer.rb:844:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:66:in `build_extensions'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/rubygems_gem_installer.rb:26:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/source/rubygems.rb:192:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:54:in `install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/gem_installer.rb:16:in `install_from_spec'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:186:in `do_install'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/installer/parallel_installer.rb:177:in `block in worker_pool'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:62:in `apply_func'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:57:in `block in process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `loop'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:54:in `process_queue'
  /var/lib/gems/2.7.0/gems/bundler-2.2.26/lib/bundler/worker.rb:91:in `block (2 levels) in create_threads'

An error occurred while installing xorcist (1.1.2), and Bundler cannot continue.

In Gemfile:
  xorcist

then used

 sudo apt install xorcist

then this shows

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package xorcist

i am following this guide

1 Like

Also Used

sudo gem install xorcist

then it comes

tBuilding native extensions. This could take a while...
ERROR:  Error installing xorcist:
        ERROR: Failed to build gem native extension.

    current directory: /var/lib/gems/2.7.0/gems/xorcist-1.1.2/ext/xorcist
/usr/bin/ruby2.7 -I /usr/lib/ruby/2.7.0 -r ./siteconf20211229-193-1acnp8c.rb extconf.rb
mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h

You might have to install separate package for the ruby development
environment, ruby-dev or ruby-devel for example.

extconf failed, exit code 1

Gem files will remain installed in /var/lib/gems/2.7.0/gems/xorcist-1.1.2 for inspection.
Results logged to /var/lib/gems/2.7.0/extensions/x86_64-linux/2.7.0/xorcist-1.1.2/gem_make.out

can you try again after running this?

sudo apt-get install ruby2.0-dev

1 Like

After This

it comes

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package ruby2.0-dev
E: Couldn't find any package by glob 'ruby2.0-dev'
E: Couldn't find any package by regex 'ruby2.0-dev'

I’d try manually this part of the install script:

git clone https://github.com/rbenv/ruby-build.git ~/.rbenv/plugins/ruby-build
rbenv install "2.7.1"
rbenv global "2.7.1"
rbenv rehash
gem update --system
gem install rails
gem install bundler

and then bundle install

3 Likes

if you’re using your OS supplied Ruby, then you’ll need to install dev packages for it; you’ll need to figure out what exactly they are named, but it will likely be a variation of ruby*-dev; perhaps ruby-dev.

Alternatively, this should also work; I believe ruby-build sets up headers for you as part of the compilation process when installing a version.
You’ll need to set up rbenv first though.

3 Likes

after running ruby-dev
and then bundle install
and after that

bundle exec rake db:create

this shows

Could not find ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3 in any of the sources
Run `bundle install` to install missing gems.

what to do next ?

1 Like

i used this sudo gem install ipaddr
then

Successfully installed ipaddr-1.2.3
Parsing documentation for ipaddr-1.2.3
Installing ri documentation for ipaddr-1.2.3
Done installing documentation for ipaddr after 0 seconds
1 gem installed

after this

bundle exec rake db:create

then it shows

Could not find ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3 in any of the sources
Run `bundle install` to install missing gems.

after that i used bundle install
then it shows

1 installed gem you directly depend on is looking for funding.
  Run `bundle fund` for details

then used bundle fund
then it shows

Could not find ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3 in any
of the sources
1 Like

if your OS is Ubuntu, please follow this guide: Beginners Guide to Install Discourse on Ubuntu for Development

It will probably work for other Debian based distributions as well.

Firstly Sorry @leonardo For Very Late Reply.
I am using Window Subsystem for linux ( Window 11 pro ) on Which i have installed Ubuntu according to this Guide-

and
when i reached the step

then this Error Comes-

Could not find ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3, ipaddr-1.2.3 in any of the sources
Run `bundle install` to install missing gems.

then used this command

And then it shows

after that i have followed these steps-

Now Can You all Advise me What to do next @leonardo @Benjamin_D @Dax