Problem with SMTP configuration

Hi!
I went through most of the “SMTP problems” threads but still cannot solve my problem.
Ubuntu in AWS EC2, fresh Discourse installation, can’t receive confirmation email.
Current configuration:

DISCOURSE_SMTP_ADDRESS: smtp.motomirko.pl
DISCOURSE_SMTP_PORT: 465
DISCOURSE_SMTP_USER_NAME: admin@motomirko.pl
DISCOURSE_SMTP_PASSWORD: secretplainpassword
DISCOURSE_SMTP_ENABLE_START_TLS: true

I can telnet to smtp.motomirko.pl 465 from instance, connection is ok.
I test my mail server with setting outlook client, and there I saw the problem. When connection was set only to TLS than it was refused, when I set to SSL than connection was successful.
I’m not really sure is it helpful.
Dump from logs : [Bash] Started POST "/finish-installation/register" for 87.206.151.152 at 2017-07-09 14 - Pastebin.com

Please help!
Cheers!

Port 465 was, many years ago, SMTP over SSL/TLS – it doesn’t use STARTTLS. I say “was”, because it’s been deprecated for so many years that the IETF has deregistered smtps as a protocol. You should use either port 25 (SMTP) or port 587 (submission) and STARTTLS.

3 Likes

Yeah, you’re absolutely right, I moved from my old provier to gmail, and now everything works like a charm! Thanks!

Gmail is not recommended as it has limits for outbound mail. Check out MailGun - it is very straight forward to setup.

3 Likes

I hope it’s ok to bump instead of creating a new topic. My host only has smtps (465/ssl) available and I can’t seem to get it to work.

  DISCOURSE_SMTP_ADDRESS: mail.myprovider.com
  DISCOURSE_SMTP_PORT: 465  # smtps/ssl
#  DISCOURSE_SMTP_PORT: 587
  DISCOURSE_SMTP_USER_NAME: login@mydomain.com
  DISCOURSE_SMTP_PASSWORD: "PASSWORD"
  DISCOURSE_SMTP_ENABLE_START_TLS: false           # (optional, default true)

These settings work in Thunderbird. Is smtps not supported or am I doing something wrong? Maybe I need to connect to mail.mydomain.com where a valid ssl cert is installed?

So my solution was first to switch to Gmail, but when google started making me problems (limits…) than i switched to MailGun like @ljpp suggested (thanks man it’s great!). I think that’s not possible to force discourse to use 465 anymore.

1 Like

Thank you. I’ve signed up for SparkPost as I don’t want to change hosts for my mail. They give you 100 mails per day without verifying your mail, 500 if you do and 10.000 if you add your credit card details. Not too bad.

2 Likes

There’s a January 2018 IETF RFC which recommends use of port 465 for “implicit” TLS. A motivation for this is the increasing trend for mandatory encryption, which renders STARTTLS somewhat redundant. RFC 8314 - Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access

Hello, I got problem to set up discourse smpt

I installed the discourse bitnami image on AWS EC2,

I followed this instruction and these checklists but no charm happens. Any idea? Thank you very much!

instruction
https://docs.bitnami.com/bch/apps/discourse/configuration/configure-smtp/

checklists
https://docs.bitnami.com/aws/how-to/use-ses/
https://docs.bitnami.com/general/how-to/troubleshoot-smtp-issues/

Bitnami isn’t officially supported, please contact bitnami directly for support.

1 Like

ok, thanks for letting me know.