Problem with Upgrade [error 137]

Did you read about the meaning of those?


Have read through those now, haven’t yet figured out how to change update settings for stable vs. main / beta / or tests-passed.

Edit: Could be the answer is there isn’t a setting for this, maybe dev updates can only be done manually or something? Am just guessing don’t know.

Side note:

During rebuild have notice that:

110:M 11 Feb 2024 04:26:05.828 # WARNING Memory overcommit must be enabled! Without it, a background save or replication may fail under low memory condition. Being disabled, it can can also cause failures without low memory condition, see To fix this issue add 'vm.overcommit_memory = 1' to /etc/sysctl.conf and then reboot or run the command 'sysctl vm.overcommit_memory=1' for this to take effect.

Not sure how to do this, how is this done does anyone know?:

add 'vm.overcommit_memory = 1' to /etc/sysctl.conf

Getting folks to Join up and be active is often a challenge. You need to seed content & discussions. Friends & Family can help. But you may also want to consider promoting your site in other social media platforms.

1 Like

This is a line in your app.yml

Best to stick with Test-passed. If on Test-passed if you wanted to switch to stable you would need to pause upgrading until stable reaches Test-passed version number. Then edit App.yml to Stable(or what it says in the app.yml comment)

Don’t know how to do that either, what is YML?

1 Like

Followed those steps to set to stable but may have made a mistake with something, since now when attempting to rebuild again reports:

(<unknown>): could not find expected ':' while scanning a simple key at line 113 column 1 -e LANG=en_US.UTF-8
YAML syntax error. Please check your containers/*.yml config files.

Discourse Doctor reports that same error again and:

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (f3856e49bfe229cf43f040aca909076ea3dadd512282ec333ae67122d327e638): Error starting userland proxy: listen tcp4 bind: address already in use
Error: failed to start containers: app
Failed to restart the container.

Darn, maybe would be a good idea to start over with this one.

Yup, you have. But this is a trivial issue. Just fix your syntax.

Am not sure what all is proper syntax, is there a way to reset to default or something?

Another report:

(<unknown>): block sequence entries are not allowed in this context at line 18 column 39 -e LANG=en_US.UTF-8
YAML syntax error. Please check your containers/*.yml config files.

Edit: seems to be corrected now rebuild is working.

Set one site to stable updates will set other one to main recent developer updates.

I think this has strayed quite far beyond the original question. Let’s close this off now it’s solved and you can start a new topic on installing a stable version. :slight_smile:

1 Like