Problems clicking topic links in IE11


(Chris Saenz) #1

I’m getting complaints just lately that topic list links aren’t working for users on IE11. They click the link but it does nothing, or loads a white page. The URL changes, but the page stays the same, or it goes blank. Opening in new tab works fine, or refreshing the page once the URL has changed.

I’ve confirmed this is happening on my site, but not on Meta. I’m on the latest beta. I’ve temporarily disabled all custom CSS styles and Babble chat plugin. I don’t know what else I can do, except to steer users to a different browser. As far as I know Discourse still supports IE11, right?

Not sure if it’s related, but in IE11 clicking the logo for “home” appears to cause a full page refresh. This happens on Meta as well.

Anybody care to have a look, it’s here: http://forum.driveonwood.com.


Babble - A Chat Plugin [ARCHIVE]
(Jeff Atwood) #2

Clicking the logo reloads the page, yes.

If you cannot repro the problem on meta, the problem is local to your site, not Discourse’s code.


(Chris Saenz) #3

Well, that’s what I’m asking… I’ve turned off everything “custom” on my site (CSS, plugins), all that’s left is vanilla Discourse. Any suggestions for troubleshooting this are appreciated.

I got no love for IE. If there’s nothing to be done, I’ll just tell users to move to another browser.


(cpradio) #4

Try directing one of them to safe mode to see if that solves it, if it does, then it is likely something in your customizations.


(Chris Saenz) #5

Good thought. I just booted Win10 into Safe Mode with Networking. No improvement.


#6

I think cpradio meant Discourse’s safe mode.


(Chris Saenz) #7

Oh, thanks! I hadn’t seen that before.

EDIT: Wow, that’s a great tool. Narrowed it down very quickly to unofficial plugins, then the Babble plugin, then specifically the full page chat option.

@gdpelican your plugin controls are not working as expected. Un-checking “Enable Babble shoutbox plugin” does not seem to globally disable the plugin, I had to also uncheck the full-page chat option box.


(James Kiesel) #8

Cool, will fix soon. :factory:


(Tomek) #9

Adding this code to < /head> fixes this issue for IE11: