Problems with docker and kernel on digital ocean

Well then… that’s reason enough to upgrade to ubuntu 16 :heart:

After the latest apt-get upgrade, the right 3.13.0-71 image-extra package was missing, hence the aufs error.

The command you linked to solved it for now, I’ll be making backups of all my discourse hosts & upgrading.

You don’t need to upgrade now…you won’t have an issue…but you REALLY should at some point :slight_smile:

3 Likes

Upgrade now, when I’m ready for issues? Or when some random apt-get upgrade will stop the show?

Hahaha, thanks, this is plenty reason to start the process of upgrading.

2 Likes

You didn’t install a package dependency, which is in the docker installation guide… that’s what caused your problem.

This has always been an odd problem to me since the official install guide says to use the wget command from get.docker.com to install Docker. And I have never observed this problem on any install we did, which obviously follows the official guide slavishly.

wget -qO- https://get.docker.com/ | sh

So this implies people who do have this problem installed Docker in some oddball, non-install-guide way… somehow.

I dunno about the docker aspect… this instance has been running fine for over a year, through other docker upgrades even.

Today I did apt-get upgrade and I got fussed at about a lack of aufs. I don’t even think it was a docker issue, but a mismatch of kernel & image-extra. If ubuntu 16 resolves that issue, I’m going to put image-extra out of my life with an OS upgrade.

This is the start of this host’s .bash_history

sudo install -o root -g root -m 0600 /dev/null /swapfile
dd if=/dev/zero of=/swapfile bs=1k count=1024k
mkswap /swapfile
swapon /swapfile
echo "/swapfile       swap    swap    auto      0       0" | sudo tee -a /etc/fstab
sudo sysctl -w vm.swappiness=10
echo vm.swappiness = 10 | sudo tee -a /etc/sysctl.conf
wget -qO- https://get.docker.com/ | sh
mkdir /var/discourse
cd /var/discourse
git clone https://github.com/discourse/discourse_docker.git /var/discourse
ls -al
vi containers/app.yml
apt-get update
2 Likes

Didn’t docker silently deprecate this method?

Nope try it yourself and see.

Too bad it didn’t include a trigger to always add the kernel’s related image-extras package.

It works – but it could stop working at any time is what I mean.

Soooo what’d they replace it with?

this – I actually use ansible to install docker in almost all cases.

Does it help prevent aufs related failures after apt-get upgrades?

Still something super hinky with this as we literally never saw this problem with hundreds of official guide based installs across a period of literally years. Did you add any “extra” stuff or steps?

(I agree it has been reported on meta a few times but I strongly suspect “extra” things were done…)

Not that I’m aware of… this host does nothing but run Discourse.

What I have seen is weirdness running apt-get dist-upgrade and I’d told myself never to run that again.

I assume that apt-get upgrade shows newer versions of packages that don’t match the kernel, and.or the kernel is silently upgraded without me knowing, causing a mismatch in the extras. (or maybe the silent upgrade is something only Linode does… I don’t know enough to know)

Regardless, I’ve come to distrust any docker upgrade because I can never tell if a bug in docker will cause an utter failure, or some other craziness.

Luckily, I have a forum that has very low use and can afford hours of downtime, so I use it as my guinea pig before I upgrade my three important ones.

The goal of this thread is to prevent such random failures… I’m hopeful that ubuntu16 does that. So far, my guinea pig forum upgraded to ubuntu16 just fine… my first real forum is busy rolling back since its boot volume was read-only after the upgrade.

No I have dist-upgraded a zillion times and never seen this.

Nope – but I use overlay2, I just recently shutdown the discourse instance on 14.04(moved it to a new server on 16.04) – which did use aufs due to overlay2 not working on that kernel line(3.13.x) – I upgraded the box regularly so I know it doesn’t cause issues…you were missing some package dependencies.

My first update to ubuntu 16 went fine, the second host’s upgrade resulted in a read-only filesystem (seems to be a common enough issue… I may simply move it to a new host as is recommended).

However, it seems that perhaps I never explicitly requested the install of the image-extras package which is required for AUFS. Since I ran the apt-get command @robbyoconnor suggested, all is well with the host/docker/discourse.

1 Like

That would be strange. It would seem that they’d change get.docker.com to do whatever the best way to install Docker was, but, from their installation page. . .

So, yeah, it does appear both deprecated and silent. It’s as if they forgot they’d created get.docker.com and just left it there.

WTF, Docker? And why do Windows and Mac users who install Docker CE get docker-compose, but not Linux? Very strange.