Will not load, no access to installation, aufs not installed - my fix

docker

(Chris Adams) #1

Basically the gist of this is that I came in to work on Monday to find that our installation of discourse was not responsive. The server is an S3 ubuntu server through Amazon. I couldn’t even shell in to the server or pingplot the domain, nothing was working. Here are my steps to fix whatever the issue was or is. It was obvious that it had something to do with aufs and the Docker software and I will explain why, even though there are other subjects covering this in different ways. This is how I fixed my issue.

I mirrored the server, just in case, because I hadn’t setup a bucket to save discourse backups…yet.
I stopped and restarted the server. With the new IP, I was able to shell in to the server. I checked TOP and found that the entire docker and discourse system had not started with the system. When I went to check ./launcher I got the error about not having aufs installed.

So I ran the following,

sudo apt-get update
sudo apt-get upgrade

The kicker is that this did not update docker or aufs, but everything else.
So I ran this;

sudo apt-get install lxc wget bsdtar curl
sudo apt-get install linux-image-extra-$(uname -r)
sudo modprobe aufs

So then I ran sudo docker run -i -t ubuntu echo 'hello' and produced an error. Docker is still not working. Ran sudo apt-get update and then sudo apt-get upgrade again and then I ran the following I found here.

sudo add-apt-repository ppa:docker-maint/testing
sudo apt-get update
sudo apt-get install docker.io

After running this command and trying ./launcher start everything looked normal. Tried using the URL to the server and poof, it worked.

I hope this information is understandable and helps others.


(Jeff Atwood) #2

Were you on 1.2 beta 6, 7 or 8? If so it was the memory bug.

That doesn’t explain aufs magically stopping working, though.


(Chris Adams) #3

I was on 8, just updated that to beta9 and it came up saying that I was using an older image for Docker within the admin, so I updated Docker and rebuilt the app via Sam’s info found here that the message linked to, but when I did that it threw up a javascript error in the website and on refresh the site is down again.

Currently running through rebuilding the app, again.


(Chris Adams) #4

And that worked. Everything is up to date and working.


(Sam Saffron) #5