ProCourse Installer - Installing/removing plugins via the UI

I have been struggling with updating.
I have successfully done it manually, but it was nerve wracking for me. I am more a wysiwyg kinda user.
I am pretty sure that I successfully updated from the admin/upgrade page
But now it is locked up again.
Is it likely that this ProCourse solution will facilitate upgrading in the future?
Jay did my install so I can say with confidence it wasn’t a glitchy install : -)
This is what I am seeing;

I have just added a plugin through ProCourse Installer, which is causing some troubles on the forum. How do we remove it, if it doesn’t appear in app.yml?

Update: @Falco Just noticed the removing plugins guide. Thank you!

It might be that if you scroll down and upgrade docker_manager first, then upgrade all button will light up.

But, if you haven’t done a command-line rebuild in the year since your install, then you probably need to. See Automatic Rebuilds when They Are Needed – Literate Computing, LLC

(Oh, maybe I upgraded you in March and you should be OK.)

1 Like

We’ve been using ProCourse Installer for a while now. We tried installing the Force Sign-In and our members started reporting that the profile picture icon in the top right corner, as well as notifications won’t work. How do we get rid of this plugin, if it doesn’t appear in app.yml? Also, it won’t appear in ProCourse Installer - Installed Plugins, where we can usually remove them. Please help!

After installing a plugin through ProCourse, I’ve noticed I am not receiving any notifications. It’s also stuck on loading, while every other member receives them.


After closing this window, the avatar image is no longer clickable until I refresh the page.

I’ve uninstalled the plugin, and also tried safe-mode with everything disabled, but still experiencing this. /u/admin/notifications is empty.

When I receive a notification, thenotification icon appears on the avatar, but still won’t load.

Update: My 2nd account works fine, so I decided to merge both using this plugin and now I’m having the same issue with the target account. Could it be something in the account settings?

Ok, some other members have reported the same issue. The toggles on the dropdown menu on the upper right won’t work for some members. Mine randomly got fixed. Please help with this, as it is a major issue people are having. Safe mode, with all plugins + theme off did not work.

Remove all unofficial plugins and rebuild.


@Falco Thanks, but we already tried disabling all in safe-mode and still having the same issue. We’ve only added one plugin and removed it. Never had an issue before that.

One thing I did recently was unlisting some About this category threads. I’ve heard deleting them would cause some troubles, but unlisting should be fine I guess. We really need to sort this out, as it’s ruining the reputation of the forum. Thank you for trying to help. Any other suggestions?

Also, new members can see Notifications in both the toggle and /u/name/notifications, while SOME older members can’t.

Safe Mode doesn’t cover all cases, so we recommend removing the plugins from the app.yml and rebuilding if safe mode doesn’t cover it.


We are using ProCourse to add plugins. We don’t have any in app.yml. I’ve asked this question several times, but never got any answers. I can remove some from the ProCourse installer and rebuild. Would that help?

@Falco Yeah, every time questions get moved to specific topics and we never receive any feedback.

That’s the plugin that he’s recommending that you remove.

@pfaffman We’ve been using it for 2 months now and never had any issues. All plugins have been added using that. If we remove it, how do we manage the plugins if we don’t have them in app.yml?

It would seem that those days are gone.

That would be the first thing to try. Have you not tried that? You’d remove either all of them, and then add them back until you see the problem, or one-by-one remove ones that you think might be causing the problem.

ProCourse Installer - Installing/removing plugins via the UI describes how to delete them if you can’t get to the admin panel.


@pfaffman @Falco Uninstalled ProCourse, as well as all other unofficial and official plugins. After rebuilding the app, still same thing. Notifications won’t login and Notifications tab appears empty for some users even if they keep receiving them.


I really don’t know what else we can do. It was clearly not coming from the plugins, but we had to try. What else could we do?

Yes. You had to try. Removing plugins is always the first step with almost any problem.

Next guess would be themes. Then ram and disk space, which also seem unlikely. Do you have swap?

1 Like

@pfaffman I’ve started a new topic since it’s not a plugin issue. I’ve mentioned everything I’ve done so far.


Hi, i tried installing a plugin but it gave a unicorn stopped unexpectly error and the plugin tab now looks like this. This is happened before to me with other plugins when installing them. Is there a way to fix this without rolling back to a backup?

@Noba Have you fixed this issue yet? I just lost all my plugins installed through ProCourse installer.

Your best and most reliable bet will be to install them in your app.yml file.

@pfaffman Yes, however our site goes down for 5-6 minutes while rebuilding and we don’t wanna do that every time we add or remove a plugin, since people start complaining. That’s the only reason why we’re using it.

We had an issue with one of the plugins, which completely broke the site, so I completely removed ProCourse Installer it from app.yml, but seems like there are still some plugins installed through ProCourse, which won’t appear in app.yml. All that made our site 4 times slower now. Any idea how to remove them?