Quick Messages Plugin


(James Hahn II) #326

Having the same problem as @Sevosik over here.


(Danny Goodall) #327

Are you on the latest version of the plugin?

Check on the ‘\admin\upgrade’ page.

I’ll have to hand you back to the authors, @Sevosik, but to help triage the problem, I’m sure it would be good to know versions of Discourse and the plugin plus the theme and device might be useful too.

Anything in the logs - Discourse and the browser console?

Can you inspect the page where QMP logo should be? Anything obviously missing?

I’m out of ideas now.


(Sevos) #328

The newest Discourse and plugin. Under /logs no any errors/warnings. In the console I see only this:

What do you need more to know?


(James Hahn II) #329

No log errors. Latest version. Been rebuilding while adding plugins all day. Just tried deleting, rebuilding, adding again, rebuilding. Still no errors and still not working for me. Clicked through all of them colors on the light theme to try and make the envelope show up and got nothing. Tried every combination of fa-envelope, envelope, fas fa-envelope, etc. out there. Nada.

Hope we can get to the bottom of this.


(Danny Goodall) #330

I’ve no idea what is happening @jameshahnii/@Sevosik· But here are some thoughts / questions that might get you closer.

Are you saying that QMP responds to interaction but the envelope doesn’t appear? i.e. You can click where the envelope ‘should’ be and it responds? Or is it that the envelope is missing and the QMP doesn’t work at all?

If it IS working but just not displaying, then can you use your browser tools to inspect the envelope element. If I do this in Chrome (right-click on envelope and hit Inspect) I get this…

<li class="header-dropdown-toggle">
  <a data-auto-route="true" title="Messages" aria-label="Messages" id="toggle-messages-menu" class="icon btn-flat">
    <i class="fa fa-envelope d-icon d-icon-envelope" aria-hidden="true">
    </i>
  </a>
</li>

What do you see? FYI the Font Awesome class in the settings should be envelope (no leading fa-).

If it ISN’T appearing or working at all, then what is the value of the following setting?

I don’t really understand what it is saying because I can’t find the Enable messages menu in header setting it refers to, but it certainly does enable / disable the messages menu.

Somewhat counter-intuitively (for me, at least) when the Quick Message User Preference setting is disabled (as it is shown here) it makes the messaging menu (the envelope) appear. Obviously, enabling it makes it disappear.

Perhaps it’s enabled for you?

Or perhaps the Enable messages menu in header option that I can’t find, is disabled for you?

I’m wondering if the setting is theme related or has been renamed or if I’m just being thick.

Lastly, what theme are you using, what device are you viewing from and have you overridden any CSS styles in the theme?

Hope some of that leads you to a solution.


(Ryan Erwin) #331

quick_message_user_preference = true enables a new user level option under your user avatar menu > interface tab…

So if you enable the user_preference then each user has to set that user preference.

You can also use the quick message required badge option to restrict who has access to quick messages, for example limiting only to staff or perhaps only to licensed or certified to encourage users to compete the discobot new or advanced user tutorial.

@jameshahnii @Sevosik would be great if you could go into admin > Settings and search for quick and screenshot all of the values that show up (as they should all he related to quick messages).


(James Hahn II) #332

Thanks @bletch. We’re not seeing the envelope at all. It just doesn’t show up. I’ve been up all night systematically removing every plugin I installed all day yesterday hoping to find a conflict, but so far I’m coming up with nothing. And I’m running out of plugins to test.

I’ve tried that button off and the other on, that on and the other off, both on, and all that good stuff. Nothing… I haven’t done any theme customizing. Standard light theme out of the box over here. I’m on a MacBook Pro Retina ~2014. Haven’t touched a line of CSS so far.

Think we’re going to have to wait for @angus to weigh in on this one.

Appreciate you taking a shot!


(Angus McLeod) #333

@bletch Thanks, that warning should be fixed.

@Sevosik @jameshahnii Sorry you’re having an issue guys.

As the installation of Quick Messages on my sandbox is working normally, we’ll (@ryanerwin is working with me on this plugin) need your help to get to the bottom of it. Please post

  1. The current values of these site settings:

    • quick message enabled
    • quick message user preference
    • quick message icon
  2. A list of all the plugins installed on your instance.

  3. Any messages in the web console that appear when you load your site (@Sevosik thanks, I see you’ve posted this already).

  4. A link to your site (if possible).

You’ve tested some of this already (changing settings and removing plugins), but there may be some clues there that can help us. Thanks.


(James Hahn II) #334

Sorry for the delay. Fell asleep working on this, woke up, and haven’t stopped since.

This is wild. In going through the exercise to take the screenshots and send over, I tried this setting again…

and it worked.

Seems there is a conflicting plugin out there and it’s one of 14. Going to start adding them back in one-by-one to see if I can uncover the culprit. Will keep you posted.

Thank you!


(James Hahn II) #335

We have a winner! Or loser, depending on how you look at it. Turns out it was discourse-mathjax.

In addition to killing QMP, it makes your Plugins >> Plugins, Akismet, Chat Integrations, & Patreon pages blank. If anyone knows @Kasper, might want to let him know.

.


Discourse Math Plugin
(Ankit Mehra) #336

You should try the official discourse plugin Discourse Math Plugin
That might work.


(James Hahn II) #337

Thanks man. I’m on it.


(Makary Gołosz) #339

I’ve noticed something today: when user receives a group message, Quick Message button in header shows new message indicator, but it does not show on the list:
image
It’s somewhat confusing, could it be easily changed, @angus?


(Sevos) #340

I wish I could use this plugin just like you :frowning: Still not working, even after a couple updates.


(Ryan Erwin) #341

@MakaryGo I’ve been working with @angus on this…

I haven’t been using group messages so I haven’t tested that, but I’m pretty sure I know where that’s happening. I’ll make sure I can reproduce, and add it to the bug list for a fix.


(Ryan Erwin) #342

@Sevosik Could you clarify what you mean by “not working”? I have run the plugin on a variety of systems… that’s not to say it’s flawless though.

Are you getting an error message?
Is the plugin showing up in your admin settings under plugins?
Have you enabled it in the admin settings?
Are you using any other plugins? Which ones?
How is your Discourse hosted?

We need some details to be able to help you.
Screenshots are often especially useful.


(David Kingham) #343

Today the message window stopped updating messages after I updated discourse, now I have to manually refresh the page to see new messages. There’s a bunch of errors in the console, here’s one:

Console Error

undefined has no properties errorLoading@https://community.naturephotographers.network/assets/application-67619619324877ff58c169ad978704406497af215c1b61758d8e37993b13f30d.js:11:8449 errorLoading@https://community.naturephotographers.network/assets/plugin-third-party-c04de63147a5ffb2056d55a1f598879c26a12874fcfadff77c2853c70981f498.js:1:1701 n@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:16:13676 refresh/<@https://community.naturephotographers.network/assets/application-67619619324877ff58c169ad978704406497af215c1b61758d8e37993b13f30d.js:10:30341 A@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:19:773 S@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:19:887 C@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:19:676 _@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:19:156 invokeWithOnError@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:7:19374 flush@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:7:19832 flush@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:7:20592 end@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:7:20937 run@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:7:22006 u@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:13:2804 e/i.error@https://community.naturephotographers.network/assets/application-67619619324877ff58c169ad978704406497af215c1b61758d8e37993b13f30d.js:7:12737 c@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:2:7300 fireWith@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:2:8054 r@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:3:11484 n/<@https://community.naturephotographers.network/assets/ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:3:16306 _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:29446:6

u _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:29446:6 o _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:29425:6 i _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:42938:6 trigger _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:57309:10 _onError/< _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:58212:10 invokeWithOnError _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:12554:8 flush _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:12613:8 flush _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:12737:8 end _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:12807:6 run _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:12921:10 u _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:33988:11 e/i.error _application-67619619324877ff58c169ad978704406497af215c1b61758d8e37993b13f30d.js:9182:8 c _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:3272:10 fireWith _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:3402:6 r _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:9311:4 n/< _ember_jquery-27e777857b8c0730dacfe09cb11711365d21a5db4f9ee0b85d494e4259cf6cda.js:9544:9


(Ryan Erwin) #344

Thanks for reporting… I’ll look into this tonight and see if I can reproduce.


(Jeremie Leroy) #345

hi guys, i hope you are well, Thanks @angus and @ryanerwin for this great plugin. I just added it and it works great.

i just noticed a little detail when adding a picture i have an error and the logs are below.

09


(Ryan Erwin) #346

@Jeremie_Leroy could you set your language to english and post that again? (verbatim error message always the easiest to research)

If not, at least a translation would be good since my french is severely lacking…

Thank you sir :wink:

@davidkingham I’ve not had time to repro yet… Hopefully tomorrow…