Quote reply is broken on Android Chrome


(Alan Tan) #1

Continuing the discussion from Discourse Narrative Bot:

The quote reply button doesn’t show up.


(Régis Hanol) #2

I will have a :eyes:.


(Tom Newsom) #3

This is the old “can’t quote the last paragraph because it includes a hidden character” problem isn’t it?


(Tobias Eigen) #4

nope - in my case it didn’t work no matter what text I selected. I did have some mixed results though - usually nothing would happen, but then if I tapped the selected text again the “quote reply” would indeed popup but over to the right. Tapping that would then have no result.

update: I just tried this on my discourse and it worked as described above. select text, tap it, see quote reply popup, select quote reply popup, see quoted text appear in reply.


(Jeff Atwood) #5

This is fiddly on iOS as well, sometimes Quote Reply won’t show up and you have to massage the selection to get it to appear. I think it’s the same “issue”, in that you have to move the selection around to get it consistently.


(Régis Hanol) #6

I will rework that code which is 2 to 3 years old now and needs some :boom: :gun:

I have some ideas on how to make it work properly on mobile too :wink:


(Jeff Atwood) #7

I think we fixed the immediate bug?

Code still needs rework of course


(Régis Hanol) #8

Here are the proper fixes :boom:

Tested on

  • latest Chrome (macOS)
  • latest Firefox (macOS)
  • latest Safari (macOS)
  • latest Edge (Windows 10)
  • latest Safari (iOS) - iPhone 6s/iPad 2
  • latest Chrome (Android) - Nexus 6p

(Alan Tan) #9

Found a small regression on mobile. When selection goes out of the cooked area, the quote reply button should not remain visible.


(Régis Hanol) #10

This is now fixed :banana:


(Jeff Atwood) #11