Rebuild container error?


#1

After I Run ./launcher rebuild app ,Being given:

Removing old container
+ /usr/bin/docker rm app
Error response from daemon: Driver aufs failed to remove root filesystem 8218bb15066b2d2ce0ba527cf68f0465759c45e06abb8b2e61b7b58b9c75620f: rename /var/lib/docker/aufs/mnt/cff411f5c6bfb54c984d35ae9871d32017ec7ee4ee806e09bef0819cbcf295c1 /var/lib/docker/aufs/mnt/cff411f5c6bfb54c984d35ae9871d32017ec7ee4ee806e09bef0819cbcf295c1-removing: device or resource busy

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: Container is marked for removal and cannot be started.
Error: failed to start containers: app

Is this what is the reason?
thanks!


(Jeff Atwood) #2

Looks like aufs support is no longer working on your server?


(Marco) #3

I’m having the same problem now, what should I do?


(Jeff Atwood) #4

Maybe remove and reinstall Docker? You’ll need aufs support for a stable filesystem.


#5

This problem has been solved for a long time. Now there’s no similar situation.


(Alan Tan) #6