Rebuild failed


I’m on this commit in /var/discourse

commit fcce1376043adeb09e21ec1ec079a41e4d29fe6e (HEAD -> main, origin/main, origin/HEAD)
Author: Chris Rendle-Short <>
Date:   Tue Dec 19 10:30:51 2023 +1100

    Bump default base image to discourse/base:2.0.20231218-0429

When I run ./launcher app rebuild I will get this error message:

Pups::ExecError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 3074 exit 1>
Location of failure: /usr/local/lib/ruby/gems/3.2.0/gems/pups-1.2.1/lib/pups/exec_command.rb:132:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"db_migrate", "cmd"=>["su discourse -c 'bundle exec rake db:migrate'"]}
bootstrap failed with exit code 1
** FAILED TO BOOTSTRAP ** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.

scrolling up, I can find this lines with and around ERROR:

2024-01-12 18:59:28.392 UTC [3090] discourse@discourse LOG:  duration: 120.113 ms  bind <unnamed>: SELECT COUNT(*) FROM (SELECT 1 AS one FROM "users" LIMIT 20) subquery_for_count
2024-01-12 18:59:33.576 UTC [3112] discourse@discourse ERROR:  MultiXactId 1127040271 has not been created yet -- apparent wraparound
2024-01-12 18:59:33.576 UTC [3112] discourse@discourse STATEMENT:  CREATE INDEX "index_topic_users_on_topic_id_and_notification_level" ON "topic_users" ("topic_id", "notification_level")
rake aborted!
StandardError: An error has occurred, this and all later migrations canceled: (StandardError)

PG::InternalError: ERROR:  MultiXactId 1127040271 has not been created yet -- apparent wraparound
/var/www/discourse/vendor/bundle/ruby/3.2.0/gems/rack-mini-profiler-3.3.0/lib/patches/db/pg.rb:110:in `exec'

Not sure how to proceed now, when I enter browser, the discourse UI just say error 500.

This is full error log:
error-log.txt (59.0 KB)

Any help in what to do next is appreciated

ok, so I “solved” this by dropping and recreating the table “topic_users” which seemed to be corrupted. Now I can see all the topic as unread but whatever …